Galaxy S4 (4.3): All contacts are saved to device. Can I change them to Google instead?

Andrew Quann

New member
Feb 28, 2014
4
0
0
Visit site
Even under "edit contact", I can't change how each contact is saved. Is there an option to change this? I would like the all to be saved to gmail instead.
 
Last edited by a moderator:

Golfdriver97

Trusted Member Team Leader
Moderator
Dec 4, 2012
35,348
103
63
Visit site
Re: GS4 (4.3) All contacts are saved to device. Can I change them to google instead?

Even under "edit contact", I can't change how each contact is saved. Is there an option to change this? I would like the all to be saved to gmail instead.

Welcome to the forums.

I think maybe if you went into your Google account by Settings>Accounts tapped on your gmail, that should bring up the list of what can be synced. If you uncheck then recheck the contacts checkbox that should force a sync. If the sync takes a couple minutes, it should be fine.
 

Andrew Quann

New member
Feb 28, 2014
4
0
0
Visit site
Re: GS4 (4.3) All contacts are saved to device. Can I change them to google instead?

This sync option on syncs contacts From Gmail to phone and my Gmail contacts is empty. I want to sync from phone to gmail as well as change the way the contacts are saved in my phone... from device to gmail. Can you help with that?
 

Golfdriver97

Trusted Member Team Leader
Moderator
Dec 4, 2012
35,348
103
63
Visit site
Re: GS4 (4.3) All contacts are saved to device. Can I change them to google instead?

This sync option on syncs contacts From Gmail to phone and my Gmail contacts is empty. I want to sync from phone to gmail as well as change the way the contacts are saved in my phone... from device to gmail. Can you help with that?

Settings>back up and reset. Is everything checked?

Sent from my Nexus 5 using AC Forums mobile app
 

keysgate

New member
Mar 25, 2014
1
0
0
Visit site
Re: GS4 (4.3) All contacts are saved to device. Can I change them to google instead?

no one seems to understand what you mean here, but I know exactly what you mean and it is so aggravating. When adding a new contact to the contacts, the default action is to save to device. I also want to change the default action to save to google contacts as the new default but can not find out how to set this. I have been all through the phone and cant figure this one out and its driving me nuts, because if I forget to change each new contact to save to google contacts, it saves the contact to the device and does not show up in contacts because I only want my google contacts to show when I view my contacts, very annoying. help someone:mad:
 

Ann Sholem

New member
Apr 26, 2014
1
0
0
Visit site
Re: GS4 (4.3) All contacts are saved to device. Can I change them to google instead?

I have a LG G2 with exactly the problem you describe. Did you ever find a solution?
 

ttbit

New member
Jan 17, 2014
3
0
0
Visit site
Mine always defaults to google. I could swear I had the choice to make it default. Have you tried resetting you defaults (under main settings/apps/contacts) and then creating a contact using google? Then try to reboot. I only looked this up as someone just asked me how I did it and I can't figure out what I did. I have an S4.
 

Aaron Bisson

New member
May 4, 2014
1
0
0
Visit site
I understand what you are saying. I had the same problem today. I bought the Galaxy S5 and thought I had all my contacts set to auto sync. So when my contacts on my S4 didn't sync up with my S5 I was a bit confused. I finally saw that they were all set to device. The way I fixed this was:

1- Enter the contacts list
2-Click menu button
3-Click on "SIM management"
4-Click "Copy contacts to SIM"
5-After all the contacts have been copied then repeat steps 1-3
6-Once in "SIM management" again click "Copy contacts from SIM"
7-Click Google account
8-Once all are copied sign into your gmail on a computer.
9-Top left says Gmail. This is a drop down menu. Click it and then pick "Contacts"
10-When this is loaded you should then see all your contacts.

This allowed me to have all my contacts directly update onto my S5. From this point on your contacts will always be on google and ready to sync to any new phone ore google device you get.
 

zylstra

New member
Aug 1, 2014
2
0
0
Visit site
Aaron, thanks for the inspiration. However, there are cases where this method won't work. For example, if half of your contacts are Google and half are Device it would be tedious to select the ones on your Device. Furthermore you wouldn't know which ones were on your Device and which ones weren't.

I suspect that you could disconnect your Google account, "Copy contacts to SIM", reconnect your Google account, then "Copy contacts from SIM".

There is ,however, another way to move your device contacts to Google contacts.
 

Dan Harmon

New member
Oct 3, 2014
1
0
0
Visit site
While googling an answer I came across a samsung site with a live chat, so I asked "Jasmine." She confirmed there's no way, on a GS4, to change the default contact location to anything but "Device."

To add a contact to gmail, you MUST click on the "+" in Contacts, then click where it says "Device" and change it to "Google" then add your contact. Annoying but I guess I'll get used to it, now that I know I'm saving it to the danged phone by default. I thought we were past the age of posting on FB: "Help! Text me your name, my phone died and I got a new one!"
 

Jen Lee1

New member
Oct 10, 2014
1
0
0
Visit site
Go to Contacts, Import from (chose sim or device, where you normally save them) and after that it will say chose location - choose Google :)
 

Markus Benz

New member
Oct 24, 2014
1
0
0
Visit site
Go to contacts -> settings -> merge contacts -> merge contacts with google.

My phone is in german so i dont know the correct english translation. This will sync all contacts on your device with google.
 

colinrlee1972

New member
Nov 15, 2014
1
0
0
Visit site
Hi everyone. On the Note 4 this can be done following the steps below: -

1. Contacts
2. Menu (top right under contacts tile)
3. Select option "Move device contacts to"
4. Select your preferred Google account

Now when you create a new contact you should see an option to select your preferred place to save contacts.

Hope this helps
Leeverage
 

shawneebear

New member
Dec 17, 2014
1
0
0
Visit site
Same issue S4 V4.4.4 and I cannot get my contacts to auto sync to google I have to use a dropdown which of course I forget to do 90% of the time it also did this on 4.4.2. I also have an S5 on 4.4.2 and it auto adds to google no problem. I have reset contact defaults stopped contacts reopened. I have reset the device. Had the device replaced. Same issue no matter what I do with the S4. I work for a cell carrier and know many people with the S4 they do not have this issue. I know people who work for cell phone warranty and problems they've seen it in other devices as well like the g3 but instead they said it was backing up to another source not the device whatever carrier they were using it was syncing to their backup system. This is driving me crazy I know quite a bit about devices and how they work but it seems that there is something I have overlooked. Samsung did not help with the issue they said it's suppose to do that. I found this amusing since I had someone right next to me with their s4 and it auto defaults theirs to their google account. I have already synced all my contacts to my google at this point but I just want to be able to add a contact by default to my google like I did with my s3 and s5 and which I know s4s do as well. Has anyone came up with a fix for this?
 

max keobounphanh

New member
Apr 13, 2015
1
0
0
Visit site
Same issue S4 V4.4.4 and I cannot get my contacts to auto sync to google I have to use a dropdown which of course I forget to do 90% of the time it also did this on 4.4.2. I also have an S5 on 4.4.2 and it auto adds to google no problem. I have reset contact defaults stopped contacts reopened. I have reset the device. Had the device replaced. Same issue no matter what I do with the S4. I work for a cell carrier and know many people with the S4 they do not have this issue. I know people who work for cell phone warranty and problems they've seen it in other devices as well like the g3 but instead they said it was backing up to another source not the device whatever carrier they were using it was syncing to their backup system. This is driving me crazy I know quite a bit about devices and how they work but it seems that there is something I have overlooked. Samsung did not help with the issue they said it's suppose to do that. I found this amusing since I had someone right next to me with their s4 and it auto defaults theirs to their google account. I have already synced all my contacts to my google at this point but I just want to be able to add a contact by default to my google like I did with my s3 and s5 and which I know s4s do as well. Has anyone came up with a fix for this?
 

Naintara Jiwnani

New member
Apr 27, 2015
1
0
0
Visit site
I have the opposite problem....
I want the default to be saved as "DEVICE" but it saves to "Samsung Account. "

Syncing with Outlook only happens if coontact is saved as a "Device" contact.
Once saved - cannot move to DEVICE.

Help Please...

N* Samsung Note 3
 

Forum statistics

Threads
941,682
Messages
6,910,069
Members
3,158,020
Latest member
sipos