Galaxy S4 help with Gmail Vibration

Barry Byrne

New member
Aug 28, 2013
2
0
0
Visit site
Hi,

Hopefully someone can help me, I have a new Galaxy S4 (my first Android!) that I am using the Gmail app for email for our Google Apps. Its all working very well, except when i receive a notification of new email through the Gmail app, it vibrates for much longer than say a Text message, and also much more forcefully.

Is there a way to customise the vibrate for just the Gmail app?

Thanks
 

srkmagnus

Retired Moderator
May 23, 2010
13,434
210
0
Visit site
Hi,

Hopefully someone can help me, I have a new Galaxy S4 (my first Android!) that I am using the Gmail app for email for our Google Apps. Its all working very well, except when i receive a notification of new email through the Gmail app, it vibrates for much longer than say a Text message, and also much more forcefully.

Is there a way to customise the vibrate for just the Gmail app?

Thanks
I don't think you can adjust the duration and intensity of the vibration from within the app settings. However, there should be third-party apps that allow you to customize this type of feature. Take a look at Tasker and see if it does what you need it to do.
 

Golfdriver97

Trusted Member Team Leader
Moderator
Dec 4, 2012
35,367
113
63
Visit site
Hi,

Hopefully someone can help me, I have a new Galaxy S4 (my first Android!) that I am using the Gmail app for email for our Google Apps. Its all working very well, except when i receive a notification of new email through the Gmail app, it vibrates for much longer than say a Text message, and also much more forcefully.

Is there a way to customise the vibrate for just the Gmail app?

Thanks

Something like that is usually baked in the ROM. However, I agree with magnus that there may be an app that allow/overrides the stock setting. Might require root access though.

From a SlimROM S3
 

Barry Byrne

New member
Aug 28, 2013
2
0
0
Visit site
Thanks All,

Getting root access isn't something that scares me, its just something I would be hesitant to do...if you know what I mean...

I will check out Tasker...
 

srkmagnus

Retired Moderator
May 23, 2010
13,434
210
0
Visit site
Thanks All,

Getting root access isn't something that scares me, its just something I would be hesitant to do...if you know what I mean...

I will check out Tasker...

Do lots of reading and understand the process before you attempt. :)

Sent from my SPH-D710 using Tapatalk 2
 

Golfdriver97

Trusted Member Team Leader
Moderator
Dec 4, 2012
35,367
113
63
Visit site
Thanks All,

Getting root access isn't something that scares me, its just something I would be hesitant to do...if you know what I mean...

I will check out Tasker...

Agree with magnus, and want to add if you have any questions, do not do anything and ask here.

Sent from a SlimROM S3.
 

droidlethus

Member
Jan 8, 2014
9
0
0
Visit site
I solved it in a way that ONLY removed the vibrate from emails. Emails still made a sound (like I want them to, but you can make them soundless), and texts still vibrate and make sound. I'll put the solution first, then background below (background can be important because different carriers have slightly different Android builds).

To solve:
  1. Open Gmail app
  2. Click the menu button softkey (in case I have the name wrong, I mean the button to the left of the physical home button)
  3. Click Settings. Here, you should see General Settings, [a list of your gmail account(s)], and About Gmail
  4. Click on an account, it will open to another menu
  5. Click on Inbox sound & vibrate (third option down for me)
  6. On this new menu, look for the following two fields: Sound (leads to a "choose file" option); and Vibrate (a checkbox)
  7. Quick side note: You may have discovered that unchecking Vibrate doesn't actually turn off vibrations. We need to go deeper.
  8. Look at the Sound option. Does it currently say Default ringtone ([your notification tone]) ? If it does, that's the problem.
  9. Click on Sound, then choose the sound you want from the menu (as opposed to leaving it on Default ringtone)
  10. Leave Vibrate unchecked (because everyone likes specificity in their instructions)
  11. Repeat for any other accounts you have
  12. Enjoy the return of a calm pocket


This way, it should still play sounds when sound is enabled, but will never vibrate. My conjecture as to why this happens: the "default ringtone" is not simply just a ringtone, but also now has the vibrate inherently attached to it (if vibrate is enabled for texts). This is also probably why we cannot change the way the texts vibrate.

I have a Samsung Galaxy S3 and am on Verizon in Oregon (in the off chance that states have different rollout dates). Before the update, which occurred this morning, my gmail notifications were set up to play the Bubbles sound (one of the stock options) and not vibrate at all. If the phone was in vibrate mode, no sound or vibration would occur, though it would still put a notification in the toolbar.

After the update, SO MANY VIBRATIONS! All of the things were vibrating. And while that isn't the only grievance I have with this update, it was the one I fixed.

Hope this helps. Verizon, if you're watching, we'd all greatly appreciate a fix to the battery drain. I remember that when a previous, non-android update caused battery drain, you all were on top of it and released a fix within a couple weeks. Do it again, please!


Edit: Though, I found out that this only works for when the phone's ringtone and notification volumes are on. When in vibrate mode, emails still vibrate =/
 
Last edited:

Forum statistics

Threads
943,148
Messages
6,917,522
Members
3,158,847
Latest member
fallingOutOfLoveWfithTech