Galaxy S6 Play Store "Your device isn't compatible with this version"

Rudokou

New member
Jul 27, 2015
2
0
0
Visit site
Hi Guys,
Just had my Galaxy S6 last week, but whenever I try to install some apps, I'be been getting alot of this error message saying "your device isn't compatible with this version"

I don't want to root my phone, hope someone can help.
Thanks!!

Posted via the Android Central App
 

wrecklass

Well-known member
Jun 8, 2010
262
4
18
Visit site
What apps are you looking at. There are apps that are specifically for tablets and others that are for specific phones. They are pretty rare, however.

--
Should there be smoke coming out of my cpu?
 

Travo79

Well-known member
Aug 4, 2013
153
0
0
Visit site
I had the same problem trying to install Waze last week. I cleared the app cache for play services, play store and rebooted. Waze downloaded and installed without a hitch after that. I honestly think that a reboot alone would have clearded it up though.

Posted via the Android Central App
 

Rudokou

New member
Jul 27, 2015
2
0
0
Visit site
I tried installing Plants vs Zombies 2, and Final Fantasy Tactics.

I attached the screenshot. I also tried clearing the cache but it didn't help.
Hope we find some solution.

Posted via the Android Central App
 

Attachments

  • 673.jpg
    673.jpg
    47.5 KB · Views: 28

jcp007

Trusted Member
May 17, 2012
6,967
83
0
Visit site
I tried installing Plants vs Zombies 2, and Final Fantasy Tactics.

I attached the screenshot. I also tried clearing the cache but it didn't help.
Hope we find some solution.

Posted via the Android Central App

Not compatible with Lollipop?

Posted via the Android Central App
 

Forum statistics

Threads
941,573
Messages
6,909,446
Members
3,157,971
Latest member
Randal