Galaxy S7 edge freezes then black screen then dead for several hours

  • Thread starter Android Central Question
  • Start date
A

Android Central Question

Hi, Have a Galaxy S7 edge that for the last week or so keeps freezing up. Then after pressing any button or buttons to try to sort it goes to the good old black screen. After that I can do nothing with the phone as it is totally dead. Plugging the charger in has no effect no lights, nothing.

So far the only thing that brings it back is to wait several hours, so far eleven or twelve at least. Then it seems plugging the charger in brings it back to life. After five or ten seconds it shows a battery icon with a flash mark. Dead battery icon I think. Then after a few more seconds that battery icon changes into a circle with 1 % in the centre and it starts to charge. After which all is well again until the next time.

Third time so far, if it comes back again. Any ideas please
 

Len Wiggins

New member
Aug 1, 2018
3
0
0
Visit site
Hi, Thanks for reply. The battery is not dead when it freezes. The first time was soon after a full charge and this last time there was at least seventy percent when it froze. But although I can do nothing with it it feels a bit warm and I assume that after the eleven or so hours that I have to wait that the battery is draining. Then when I plug the charger in it is a dead battery but not when it first freezes. Like I said once it is frozen there is nothing, no lights, no tones, nothing even if I plug the charger in. Until after waiting several hours.

Hopefully it will be working again later tonight or tomorrow morning for a while again, just like it did the last two times.

Thanks again
 

Len Wiggins

New member
Aug 1, 2018
3
0
0
Visit site
This time I only had to wait about seven hours. Seems whatever it is drains the battery after it freezes and becomes unusable. Then after battery is completely drained I am then able to get it to charge again. Until the next time that is )-:
 

belodion

Co-Ambassador Team Lead
Moderator
Jun 10, 2014
39,441
309
83
Visit site
It could be a bad battery, or possibly some hardware or software fault.
I’ll move the thread to the S7 Edge forum for suggestions.
 

Trending Posts

Forum statistics

Threads
944,342
Messages
6,922,399
Members
3,159,506
Latest member
RVHauler