Google Calendar no longer syncing on S4

mwventura

Member
Sep 9, 2014
22
0
0
Visit site
OK, so recently AT&T rolled out 4.4.4. I upgraded, everything worked fine. Then I decided to remove Facebook from my phone, and wrote did a couple of things break big-time.

One was easy enough to fix - my contacts became corrupted, but since I store everything on Google I just deleted all contact info in application manager and everything pretty much synced back up.

My calendars, though, have never recovered. I've uninstalled the Google calendar app and reinstalled, I've tried using the stock calendar, but I can not get any calendar info on my phone. In Google calendar, when I hit the settings drawer it says No calendars selected to sync.

I've gone into Google account settings and manually done a sync. I've cleared calendar cache(s) (both Google and stock) in application manager. Uninstall, reinstall. Nada.

Calendars are syncing fine on my Nexus 7 so this is just an S4 issue. I mention Facebook earlier because I am convinced that deleting their app is related.

If anyone has had a similar calendar issue and managed to solve it, I'll buy you a beer if you can throw some advice my way. (Restrictions apply, limited time, etc.)

Thanks!

Posted via the Android Central App
 

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
164,929
3,928
113
Visit site
Welcome to Android Central! Have you tried removing your Google account completely in Settings>Accounts​, then adding it back again?
 

mwventura

Member
Sep 9, 2014
22
0
0
Visit site
OK, just tried that but no dice. Weirdly (and somewhat related), I can find nowhere on the phone to add a calendar account. In attaching a screenshot of what Google calendar tells me; stock calendar has even less to say.

Posted via the Android Central App
 

Attachments

  • Screenshot_2014-11-19-22-30-57.jpg
    Screenshot_2014-11-19-22-30-57.jpg
    24.4 KB · Views: 17

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
164,929
3,928
113
Visit site
From that screen, tap Settings. Do you see your Google account listed there, with the calendars below?
 

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
164,929
3,928
113
Visit site
Hmm. I think you did this already, but just to make sure--go to Settings>Accounts-Google>[your Google account]​, and make sure Calendar is checked.

Also, in Settings>Apps>All, select Calendar, and Clear Data along with Cache. Then open it again and see if it resyncs.
 

mwventura

Member
Sep 9, 2014
22
0
0
Visit site
So there are notices about sync issues (that again arrived after deleting Facebook app). And interestingly: in the Google accounts, no option to sync calendars at all.

Posted via the Android Central App
 

Attachments

  • Screenshot_2014-11-20-22-12-16~01.jpg
    Screenshot_2014-11-20-22-12-16~01.jpg
    56.6 KB · Views: 15
  • Screenshot_2014-11-20-11-32-41~01.jpg
    Screenshot_2014-11-20-11-32-41~01.jpg
    11.3 KB · Views: 38

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
164,929
3,928
113
Visit site
That's really odd. Have you disabled any apps? Like Calendar Storage? Go to the App Manager, tap the Menu button, then tap Reset All App Preferences (which re-enables all disabled apps). Then reboot, and see if you get the Sync Calendar option back.
 

mwventura

Member
Sep 9, 2014
22
0
0
Visit site
WINNER! I didn't even restart the phone.

You know, I was probably trying to find a way to get the annoying stock calendar to leave me alone and must have disabled something at that time. (It has a habit of turning its notifications back on no matter what i do.) Guess I can stop blaming Facebook for this one.

Thank you for sticking with it - I guess in hindsight it's better to get 2 calendar notifications rather than none!

Posted via the Android Central App
 

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
164,929
3,928
113
Visit site
Awesome! If you don't want the stock Calendar to give you notifications, you should be able to turn them off in the Calendar app's menu, or uncheck "Show notifications" in Settings/Apps/All on the Calendar app info page.

Posted via Android Central App.
Please excuse any typos or autocorrect derps.
 

mwventura

Member
Sep 9, 2014
22
0
0
Visit site
Yeah, Samsung is terrible about this stuff. I think that resets every time the phone restarts or the app updates or something. It is so obnoxious.

Nice Crow avatar, btw!
 

melanied

New member
Mar 26, 2014
1
0
0
Visit site
I tried what you suggested. Didn't work for me. Unfortunately I didn't come across this thread until just now. Got frustrated a few days ago and thought maybe deleting the stock calendar would help, and now I can't get it back. Do I need S planner for any calendar to work or is there a way around it?
 

Joe Lowry1

New member
Dec 30, 2014
1
0
0
Visit site
I made a loggin just to thank you for this. I use my calendar for business during the warm weather so didnt notice it wasnt updating till today. unsure how long it has been not working but it was aggravating because all of the things I was trying that people said wern't working and as the previous poster mentioned the options weren't even there to select.lol. thank you and best wishes.
 

John Boyle2

New member
Feb 12, 2015
1
0
0
Visit site
My wife discovered that her calendar was not syncing with Google. She uses the default calendar (not the Google calendar). I went into Applications and cleared the cache and data for that calendar. It cleared everything off that calendar. Shortly it synced everything back. She then made a new events at the Google Calendar on internet and on her phone calendar. Syncing in both directions works. Thanks for the help tips!
 

Forum statistics

Threads
941,363
Messages
6,908,302
Members
3,157,881
Latest member
MelissaCollins