Google Contacts non stop "Getting contacts, this may take a while..."

onthemove

Member
May 10, 2023
22
2
3
Visit site
I just got a new Google Pixel 6a. After setting up, I found out everytime I open the Contacts app, the message "Getting contacts, this may take a while..", keeps showing up, with the updating bar below moving non stop, as if it is updating the contact list all the time.

From what I can see, the contact list is already completely restored. I tried stop all the sync, clear the cache and storage for the app, even force stopped the app, nothing works.

The app works okay but it is just annoying to see that. It might be draining my battery are well.

Some extra information. My old phone went completely dead, couldn't get started at all. I am not sure if that affects the the new phone when restoring my contacts.

Also, I am a retiree, don't need to sync anything on my phone. When I turn on automatic sync, the phone also had trouble syncing. Keep telling me to try later. But that doesn't bother me since I can turn that off.

I Just want to get rid of that annoying message. I don't mind uninstall the Contacts App (I believe it comes with the phone), but don't know how.

Attached is a screen shot of the problem.

Any help welcome. Thanks.

Screenshot_20230510-070915~3.jpg
 

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
165,965
5,277
113
Visit site
Welcome to Android Central! Are you syncing the phone with your Google Contacts in the cloud, or some other account (like an Outlook account)?
 

onthemove

Member
May 10, 2023
22
2
3
Visit site
Maybe I should back up a little. During set up, at one stage during syncing Contacts the process got stuck at 64% and just hang there (no problem using the phone though). No matter what I did, the set up screen remained the same, not moving at 64%. The contact list again looked complete.

I googled about contacts syncing problems, and found out sometimes foreign characters contact names, which I have quite a few, could be problematic during syncing.

So I went in and get rid of all the foreign characters, and that problem is solved, but left with current problem.

See attached screen shot of previous problem.

Screenshot_20230510-111953.jpg
Does this persist if you change your connection, like on different wi-fi networks
Yes. It is still there if I am connected via mobile network.
 

Attachments

  • Screenshot_20230510-111953.jpg
    Screenshot_20230510-111953.jpg
    68 KB · Views: 7

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
165,965
5,277
113
Visit site
Hmm. Any contacts that have attached notes? If so, make sure there aren't any atypical characters there either.
 

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
165,965
5,277
113
Visit site
Try clearing the app cache/data again for the Contacts app, but this time, also do the same for the Contact Storage app (you need to select the Show System option to see it in the Settings>Apps list). Then sync again.
 

onthemove

Member
May 10, 2023
22
2
3
Visit site
Try clearing the app cache/data again for the Contacts app, but this time, also do the same for the Contact Storage app (you need to select the Show System option to see it in the Settings>Apps list). Then sync again.
I did clear both contacts cache and storage a few times already. It does not work.
 

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
165,965
5,277
113
Visit site
I did clear both contacts cache and storage a few times already. It does not work.
Just wanted to clarify -- you mean that you cleared app cache/storage for the TWO system apps called Contacts and Contact Storage, right? The way you worded it sounded like you might still just be referring to the Contacts app alone.
 

onthemove

Member
May 10, 2023
22
2
3
Visit site
Just wanted to clarify -- you mean that you cleared app cache/storage for the TWO system apps called Contacts and Contact Storage, right? The way you worded it sounded like you might still just be referring to the Contacts app alone.
I went into my app list and there is only one Contacts app. No Contacts Storage app like you mentioned. See below.
Screenshot_20230511-061852~2.png

Unless it is some place else that I fail to locate.

When I said I clear the cache and storage of my Contact App, I meant as per attached below.
Screenshot_20230511-061543~2.png
 

onthemove

Member
May 10, 2023
22
2
3
Visit site
Anyway, I thought it was going to be an easy fix. Apparently not.

Besides this, the phone functions well. I also do not need to sync everything that I have on my phone.

I really don't want to take up too much of everyone's time. I appreciate all the help. Thank you.
 

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
165,965
5,277
113
Visit site
I went into my app list and there is only one Contacts app. No Contacts Storage app like you mentioned. See below.
View attachment 353336

Unless it is some place else that I fail to locate.

When I said I clear the cache and storage of my Contact App, I meant as per attached below.
View attachment 353337
In the Settings>Apps menu, tap the 3-dot menu button at the upper right and select Show System (that's what I was referring to previously) -- then you'll see the Contact Storage app show up.
 

mustang7757

Super Moderator
Moderator
Feb 6, 2017
92,151
6,706
113
Visit site
I did that only once, as the last resort. The "getting contacts.." thing stopped for a while, then came back again.
Go to settings>apps >3 dots upper right corner tap>look for device setup clear data then force stop it if still happening then find System UI clear its data then force stop it Screenshot_20230510-212524.jpgScreenshot_20230510-212615.jpg
 

Trending Posts

Forum statistics

Threads
944,526
Messages
6,923,197
Members
3,159,606
Latest member
JaysonIrwin