Google Play forces closed.

f1usgp

Active member
Sep 22, 2010
33
0
0
Visit site
I moved Play to my SD card via Titainium Back Pro to free up more space on the phone. And now everytime I open Play it forces closed on me. I have tried wiping cashe and that did not help. I also ran Fix Permissions in ROM Manager and that did not help. Does anyone have any ideas? Thanks.
 

Captain_Throwback

Well-known member
Jan 16, 2011
324
26
0
Visit site
I moved Play to my SD card via Titainium Back Pro to free up more space on the phone. And now everytime I open Play it forces closed on me. I have tried wiping cashe and that did not help. I also ran Fix Permissions in ROM Manager and that did not help. Does anyone have any ideas? Thanks.
Moving the Play Store is not a good idea. It never works right if it's moved. I recommend just moving it back.

P.S. Get rid of ROM Manager and make sure you're using an Amon_RA-based recovery. CWM is unreliable on the EVO 4G.
 

f1usgp

Active member
Sep 22, 2010
33
0
0
Visit site
Moving the Play Store is not a good idea. It never works right if it's moved. I recommend just moving it back.

P.S. Get rid of ROM Manager and make sure you're using an Amon_RA-based recovery. CWM is unreliable on the EVO 4G.

I had to find the Play apk and load it. I have left it on the phone since then.
So what recovery do you recommend? And how can I download it if Play keeps closing?
 

Captain_Throwback

Well-known member
Jan 16, 2011
324
26
0
Visit site
I'm new at this so I'm not sure what I am doing. How do I go about loading this? Un-install ROM Manager first?
I would uninstall ROM Manager first, yes. Before we start, I'll need to know how you rooted? And did you take the latest OTA (the one with Sprint's Connection Manager - 5.07.651.1)? Depending on the method you used, the below procedure might not work (you could get a "Main Version is older" message). However, I'll post the procedure here anyway, as it will still apply. It's possible I'll just have to make you a file that will work specifically for your situation.

---------------------

Download one of the PC36IMG.zip versions of smelkus' recovery (choose whichever theme you prefer). Copy the file to the root (not in any folders) of your sd card, and rename to only "PC36IMG.zip." If your file explorer is hiding extensions, you will not need to add the ".zip."

Once that's done, make sure fast boot is disabled (should be under Settings -> Applications). Power off the device.

Once the device is powered off completely, hold the volume down button, and press and hold the power button until the HBOOT screen appears. After briefly showing a menu, it should automatically read the PC36IMG.zip file from the sd card, and ask you whether you want to update. Choose "yes". After the update is complete, choose "no" to the reboot question, and then choose "Recovery" to boot into your new recovery.
 

f1usgp

Active member
Sep 22, 2010
33
0
0
Visit site
I rooted about a year ago using the Clockwork Mod. I did not take the latest OTA. I am on software # 4.24.651.1, Android 2.3.3.

What's the difference between the themes?
 

Captain_Throwback

Well-known member
Jan 16, 2011
324
26
0
Visit site
I rooted about a year ago using the Clockwork Mod. I did not take the latest OTA. I am on software # 4.24.651.1, Android 2.3.3.

What's the difference between the themes?
The procedure I posted should work for you, then. The difference in the themes is just the color of the text and the picture in the middle of the screen. They all work the same otherwise.

P.S. I guess a better question would've been what procedure did you use to unlock your bootloader. Either way, you should be fine with the method I posted.
 

f1usgp

Active member
Sep 22, 2010
33
0
0
Visit site
Ok. I followed your instructions just fine. Thanks. Should Google Play now work for me? Or do I need to do anything else?
 

Captain_Throwback

Well-known member
Jan 16, 2011
324
26
0
Visit site
Ok. I followed your instructions just fine. Thanks. Should Google Play now work for me? Or do I need to do anything else?
Now, do a fix permissions (under Other) and wipe the caches.

I'm not sure why you had to reload the Play Store, though - why didn't you just use Titanium Backup to move it back? Also, when you 'reloaded' it, did you put it back in /system/app where it belongs, and change the permissions appropriately? Or did you just install it like a regular app (which won't solve this problem).
 

Forum statistics

Threads
944,508
Messages
6,923,118
Members
3,159,593
Latest member
designdigitalhub