Google Talk Away Status

icebike

Well-known member
Apr 8, 2010
1,726
115
0
Visit site
Ok I can't tell if this is the HTC One, or Android ICS that is doing this, but it has definitely changed since my Nexus One.

I use Google Talk to chat with lots of other Jabber users. Google Talk is inter-operable with Jabber.

1) When the Nexus One goes to sleep, your on line status stays as On Line.
2) When the HOX goes to sleep it notifies your correspondents that you are away.

#1 is the correct behavior, #2 is not correct.
Your phone is always with you, so it never really should show off line as long as you are logged in and connected.

I noticed this change when moving to my HOX (international). But I can't determine if its
ICS or HOX that is the problem.

Your correspondents can still send you messages, they just have to learn to ignore the "away" status.

(And yes, I realize this is corner case, and not everybody uses this interoperability).
 

anon(21022)

Well-known member
May 8, 2010
327
10
0
Visit site
Isn't there an option in the Talk settings to set as away when screen turns off? Maybe that's what's going on...

Sent from my HTC One X using Tapatalk 2
 

icebike

Well-known member
Apr 8, 2010
1,726
115
0
Visit site
Isn't there an option in the Talk settings to set as away when screen turns off? Maybe that's what's going on...

Sent from my HTC One X using Tapatalk 2

Yes, and i have that unchecked. I should have mentioned that.
It seems to act the same when checked or unchecked.





?
 
Last edited:

sfbayboater

Member
Jan 15, 2011
6
0
0
Visit site
I'm pretty sure it has been this way since gingerbread. Under settings it is mobile indicator. It is to show people that you are not currently active in Google talk but are still available.
 

icebike

Well-known member
Apr 8, 2010
1,726
115
0
Visit site
I'm pretty sure it has been this way since gingerbread. Under settings it is mobile indicator. It is to show people that you are not currently active in Google talk but are still available.

No, mobile indicator is different, it shows a little android symbol in other people's list of contacts to distinguish android users from iPhones, or desktop users.

That's totally different than the away indication status messages sent invisibly over the network to the server.

You won't even see the away indication on Android. On another XMPP client you will. Such as on a Linux client like kopete.
There is a setting in Google talk advanced settings that is supposed to control this, and it worked on gingerbread and honeycomb, but that setting is ignored on ICS.

Multitasking does not seem to be involved because launching any other tasks does not trigger the away message, only sleeping the phone.


Sent from my HOX
 

abhijit1289

Active member
Apr 23, 2012
44
5
0
Visit site
Don't know what your talking about. All the three xs I've come across after reading this don't have this issue. Try reinstalling talk :D

Thank me if I helped.... You know I'll do it again :) Oh, and by the way, Sent from my HTC One X
 

icebike

Well-known member
Apr 8, 2010
1,726
115
0
Visit site
Don't know what your talking about. All the three xs I've come across after reading this don't have this issue. Try reinstalling talk :D

Thank me if I helped.... You know I'll do it again :) Oh, and by the way, Sent from my HTC One X

So which Jabber Clients did you test with? And were they windows or linux clients?