Hard Bricked?


New member
Jan 4, 2013
Visit site
So I tried rooting my Koodo SGH-T989D, I got the clockwork thing on and I made a backup and fixed permissions, then when it came to installing a zip file from SD card I picked a different one I thought would work, I followed a guide from a different forum. Since my Device (Samsung Galaxy SII X) came with Android 4.0.4 I decided the zips provided in the tutorial wouldn't work because it said they were for 2.X so I just googled a superuser app and picked one that said 4.0.4 in haste (REALLY bad idea in hindsight) and it said it installed successfully but when I selected reboot it just went black and wouldn't turn on, now it won't turn on, no download mode, no recovery mode, no tricks to make odin recognize it. Of course I probably haven't tried every trick to make it work, so if somebody has something other than "plug it in remove the battery do the download mode combo and insert the battery" then please speak up. I just end up with some weird driver that ends in DLOAD. Does anyone know how to fix this besides jig/JTAG because I'm going to try a jig later. If I end up having to send this away and praying for warranty do you think my count will have been raised? Thanks.

Leo Nardo

New member
Feb 4, 2013
Visit site
Same here!!!! HARD BRICK!!! Rooted and installed a new Android ROM for my galaxy ace S5830i (ClockWork Recovery), on the first attempt the jellyblastv3. The Rom worked but could not find any gsm or 3g network. O2 UK, tried with other sim cards too. So i formatted it again and installed another ROM, it did not work at all, and I think is what you call Hard Brick. I could NOT get access to recovery or download mode, tried Odin and all the i could try with a computer, a cable, the phone and internet connection. Not able to make my phone start I took downtown, 2 shops. They tried odin, jig and nothing. Cant Start
Then I took the phone to this new shop it has just been refurbished everything is new, they did it in less than an hour.
I wonder if they had another piece of equipment or someone that knows more. Could not find on the Internet. (Information its a mess lol)
The problem is. They Flash a different Rom to my original S5830i. Now the battery life is half of what it was. Draining over night on stand by, charged by night, when I wake up it has only 30% left.
I want to update for a battery efficient ROM but dont want to stay another 4 days without a phone again so when I know it I do it again :p
The mystery of getting it up again
How to start the recovery/download mode when the Buttons Combo, JIG and Odin fail to do so

If anyone can help me getting a ROM that runs on:
PDA : S5830iJLB1
CSC : S5830iOJPLA5
Last edited:

Trending Posts

Forum statistics

Latest member