Hardware buttons not working anymore (AW 2.0)

Axxxxel

Member
Nov 30, 2016
9
0
0
Visit site
Hi,

after one of the latest updates my upper and lower hardware button doesn't work anymore.
The watchface is black shortly and comes back and nothing happens afterwards. Even no change after a factory reset.

I'm on AW 2.0 preview 4 (same build as 5 - NVF41U)
Android Wear 2.0.0.146809763
Play Services 10.1.33 (534-138250150)

Anybody having the same problem?

Cheers
Axel
 

Jeeze

Member
Dec 17, 2015
16
0
0
Visit site
It is broken again. I had put on preview last night, and I am sure after the Google and the Wear update mid morning
broke it..again.
 

jkassay

Member
Jun 16, 2011
7
0
0
Visit site
Had the same problem. Had to re flash the preview. I think that update was meant for non wear 2.0 users and it caused havoc for preview users.

That update was not Android wear 2.0, but was an update of GAPPS which is not compatible with the GAPPS on the OS 2.0 preview.
 

John Dodson1

Active member
Aug 6, 2015
36
0
0
Visit site
Have you turned the brightness down? I have this issue as well but it's worse when I turn the brightness down. Keep it turned up and battery life will be worse but it'll be more useful.
 

tech_head

Q&A Team
Aug 25, 2010
783
15
0
Visit site
It is broken again. I had put on preview last night, and I am sure after the Google and the Wear update mid morning
broke it..again.

Same issue wth my LG Urbane 2.
As long as I remove the Wear update things work.
As soon as that updates it breaks again.
 

miroul

Well-known member
Apr 13, 2016
73
0
0
Visit site
Same issue here with U2 running AW 2.0 dp4. That's a drag but I can live with it. I'll try the reset tomorrow and see if it works for me.
 

jkassay

Member
Jun 16, 2011
7
0
0
Visit site
You can uninstall the update from the watch. this will save you from having to re-flash the preview. worked for me when I had automatic update on, and had to do it a second time.
 

Axxxxel

Member
Nov 30, 2016
9
0
0
Visit site
When you uninstall Wear from the watch Play Store it's a downgrade to the preinstalled version of your preview.
The buttons bug is fixed and at the beginning I had also the impression that my watch is also running smoother. Not sure.

Don't forget to switch off automatic updates.