having trouble with getting custom theme app and icons

bears6ga

Member
Aug 22, 2011
12
0
0
Visit site
i have flashed the bluesteel theme from team carbon on my optimus s running cm7 and everything is themed except for the app icons and i dont know how to get it to work..i have even purchased the theme on the market thinking that would fix the problem since it says it has over 200 apps and icons themed and i keep getting "improperly compiled error" and did what it says to fix it and it still wont work. what do i need to do to get the themed apps and icons to work? please help!!
 
Last edited:

graphic1982

Well-known member
Jul 27, 2011
55
5
0
Visit site
i have flashed the bluesteel theme from team carbon on my optimus s running cm7 and everything is themed except for the app icons and i dont know how to get it to work..i have even purchased the theme on the market thinking that would fix the problem since it says it has over 200 apps and icons themed and i keep getting "improperly compiled error" and did what it says to fix it and it still wont work. what do i need to do to get the themed apps and icons to work? please help!!
just a shot in the dark here, but did you restart the phone after applying the theme? the app icons won't switch to the new themes icons until you restart the phone.
 

graphic1982

Well-known member
Jul 27, 2011
55
5
0
Visit site
yea it was the first thing i tried when the apps didnt change and nothing happened
strange.....i actually used to run this theme on my EVO before it broke on me, never had a problem with it. Have you tried applying the metamorph's to see if they change anything?

EDIT: I was curious about this so i downloaded the apk and extracted it and there is no "drawable-mdpi" folder in the theme. I'm pretty sure that means you won't get everything out of the theme as it looks to only support HDPI phones.
 
Last edited:

bears6ga

Member
Aug 22, 2011
12
0
0
Visit site
hmm...i will try metamorph when i get home and see if anything changes but yea im sure the drawable-mdpi folder is probly the reason it isnt workin like it should. most of it works just not the app icons which kinda sucks but hopefully metamorph will fix it. thanks for lookin. this is the first ive seen about why this would be happening and ive been looking everywhere for answers
 

graphic1982

Well-known member
Jul 27, 2011
55
5
0
Visit site
hmm...i will try metamorph when i get home and see if anything changes but yea im sure the drawable-mdpi folder is probly the reason it isnt workin like it should. most of it works just not the app icons which kinda sucks but hopefully metamorph will fix it. thanks for lookin. this is the first ive seen about why this would be happening and ive been looking everywhere for answers
no problem. the more i think about it, i'm pretty positive that the missing drawable-mdpi folder is your issue. i took a look at the available metamorphs and it doesn't include any of the app icons in it, just some unlock screen adjustments and menu colors.
 

bears6ga

Member
Aug 22, 2011
12
0
0
Visit site
is there any way of getting the custom apps and icons for this theme? or will i just have to live without them and keep what parts of the theme i got
 

graphic1982

Well-known member
Jul 27, 2011
55
5
0
Visit site
i guess you could get them from the drawable-hdpi folder and resize them for mdpi. good luck trying to recompile the theme though. i've never had luck editing a theme for CM7.