HELP HELP HELP - Ive tried everything to root and update firmware on my samsung galaxy s3 sph-l710

Adrienne Pena

New member
Mar 11, 2014
Visit site

i have sprint samsung galaxy s3 sph-l710 = and i have transferred to straight talk network, but unfortunately i havent been able to get my service due to the fact everything is updated but the firmware, so i googled and found that i could use kies 3 to update the firmware which went thru the whole process and said was successful but when i tried to retrieve my network it still said that firmware not updated. but it updated the whole phone like it was a new everything then uploaded all my back then i researched again and found that i could root the darn phone using sprint gs3 root kit. i did everything it said and when its supposed to go to the flashing root in recovery and be touch screen it doesnt do anything at all just staying in download mode......i dont know what to do from this point on i have been at this for 3 days know all day till 4 am and im about to throw the phone away!! any advice to help me i would appreciate it. i have gone in to play store and downloaded busybox, superuser and fixer, rom rooting guide, root checkers, terminal emulator, abd toggle, and even pd for mobile so past the point of frustration that i cant even think anymore...i have this android central app and have been reading forums to. i tried kingo root and said was successful and really wasnt. please please someone anyone help!!! :mad::-\:':)(

Trending Posts

Forum statistics

Latest member