HELP!!!! I rooted my phone and then did a fatory reset and now the screen is blank!! :( please help!


AC Question

I have a ZTE Imperial android phone running 4.1.2. So I wanted to get 4.4 on it so I rooted it and it didn't work lol I didn't really know what I was doing I thought you just had to root it.. Anyways I wanted my phone back to the way it was (unroot) so I did a factory reset on my phone in my settings so I let it do it's thing and then I came back in my room to find the screen was blank. So I restarted it and now all it does is show ZTE Logo and then goes to blank screen. I don't think its bricked.. I can boot it into recovery mode but that doesn't help I also tried to reset it into recovery mode but it still doesn't do anything :(. I tried flashing it with different roms and that didn't work either it says installation aborted. Can anyone please help me and maybe find me a rom so I can flash my phone please anyone help I just want my phone back :(

Trending Posts

Forum statistics

Latest member