Help really screwed uppp!!!!

Adam Mahaney

New member
Dec 22, 2012
Visit site
So I originally rooted my S3 using odin and a stock verizon software followed by using ez bootload unlock, ez recovery, and clockwork mod. I used the custom rom cyanogen mod, and eventually continued to update those roms when they rolled out the OTA updates. When the latest update came out on the 18th I noticed an issue with my contacts. Due to this I reverted to the 16th rom, but something went terrible wrong. At this time I tried re-rooting, tried different types of rooting and got my device working along with my contacts back, but it rendered my sim card useless. I tried everything I could find on the internet. I finally covered my tracks and took it to the verizon store. They replace the sim card, but it still didn't work. They replaced my device, and me being dumb rooted it again. Same original rooting that worked the first time. It worked at first, but then the same issue occurred. I'm not sure what to do, I can't go back to verizon again. They will expect something this time. It makes no sense. The hardware is not an issue, there is some data error somewhere. PLEASE HELP!!!

TLDR; Crazy weird data issue maybe? Whoever can solve this will be the House of Android rooting.


Nov 29, 2010
Visit site
did it work when you got the new device? Have you checked that data is turned on and that the network is set right? So you rooted, but was it a stock ROM?

Forum statistics

Latest member
Moore Rebecca