Here's how to force update 4.3 OTA on your GS4 GPE

jd914

Banned
Feb 3, 2010
798
36
0
Visit site
go to settings>apps>all>Google services framework

clear cache
clear data
force stop

go back to system updates and select "check now" your OTA will begin

It worked for me

ENJOY!!!!
 
Last edited:

jd914

Banned
Feb 3, 2010
798
36
0
Visit site
Update went flawlessly!

Sent from my GT-I9505G using Tapatalk 4 Beta
 

Attachments

  • uploadfromtaptalk1375497714268.jpg
    uploadfromtaptalk1375497714268.jpg
    154.8 KB · Views: 98

planoman

Well-known member
Aug 12, 2010
3,605
94
0
Visit site
Let us know what you think after a day or so. I wont force it so it could be a week or more before I get it. I should know what to expect by then!
 

jd914

Banned
Feb 3, 2010
798
36
0
Visit site
Let us know what you think after a day or so. I wont force it so it could be a week or more before I get it. I should know what to expect by then!
I can tell you now right off the back it feels a lot smoother. Dolphin Browser used to have stuttering when scrolling and especially when exiting. It was really bad and I thought it was an issue with the app itself but that didn't turn out to be the case. This was bugging the hell out of me. Just on this alone I can tell that 4.3 offers under the hood improvements. I'm also impressed how fast this update was released. If this is the case I'm completely sold on Google Play Edition phones. I used to be a Nexus only guy but I'm very pleased with my GS4!
 

planoman

Well-known member
Aug 12, 2010
3,605
94
0
Visit site
I can tell you now right off the back it feels a lot smoother. Dolphin Browser used to have stuttering when scrolling and especially when exiting. It was really bad and I thought it was an issue with the app itself but that didn't turn out to be the case. This was bugging the hell out of me. Just on this alone I can tell that 4.3 offers under the hood improvements. I'm also impressed how fast this update was released. If this is the case I'm completely sold on Google Play Edition phones. I used to be a Nexus only guy but I'm very pleased with my GS4!

I thought this after I updated my Nexus 7 to 4.3. It seems much smoother like they threw some more butter in there! I have not spent much time with my Nexus 7, so I am not sure if the update borked anything. Appreciate the feedback and thoughts!
 

PhxBlue

Super Geek
Aug 16, 2010
119
2
0
Visit site
In this 4.3 build for your GE devices does 4.3 fit the icons and widgets any better onto the home screen? It looked like in 4.2.2 that there were excessively large margins at the top and bottom of the screen below the persistent search bar and above the software navigation buttons.
 

TrivialTweeter

Well-known member
Nov 18, 2010
57
5
0
Visit site
This definitely does NOT work on my GE S4. Tried multiple times. I'm still on 4.2.2.

I tried many times as well, and did not receive the update. I then followed the steps above, but this time I unchecked the "show notifications" box. I went to check for a system update, and got the prompt that the 4.3 system update is available. It says that the update is available "via Wi-Fi only until August 4th". So make sure you're connected to a WiFi network when doing this. Hope it works for you. Good luck!


Screenshot_2013-08-03-00-03-30.png
 

quietlybrilliant

Well-known member
May 12, 2013
457
0
0
Visit site
I tried many times as well, and did not receive the update. I then followed the steps above, but this time I unchecked the "show notifications" box. I went to check for a system update, and got the prompt that the 4.3 system update is available. It says that the update is available "via Wi-Fi only until August 4th". So make sure you're connected to a WiFi network when doing this. Hope it works for you. Good luck!


View attachment 75562

Thanks. Tried it again this time unchecking the show notifications box. Still didn't work. Maybe it just takes several tries and it was a coincidence in your case that it worked exactly the one time you had that box unchecked.
 

TrivialTweeter

Well-known member
Nov 18, 2010
57
5
0
Visit site
Update: it worked for me after I turned "Show notifications" back on! Go figure. Must be coincidental.

Glad you got it.

I didn't watch the upgrade process after I clicked on the "reboot and update" button. When the phone booted back up I saw that I was still on 4.2.2 :-( I went through the steps again, and yes it does take many attempts before it'll work. When it rebooted into recovery to apply the update it appeared to get about half way through and then I received an error message. Not sure why it errored out. Could it be because I am rooted?
 

maverick96

Well-known member
May 16, 2010
989
10
18
Visit site
Does this fix the camera issue? Where if you take a picture with the phone being up and down it automatically turns picture sideways?

Sent from my HTC One using Tapatalk 4 Beta
 

planoman

Well-known member
Aug 12, 2010
3,605
94
0
Visit site
Glad you got it.

I didn't watch the upgrade process after I clicked on the "reboot and update" button. When the phone booted back up I saw that I was still on 4.2.2 :-( I went through the steps again, and yes it does take many attempts before it'll work. When it rebooted into recovery to apply the update it appeared to get about half way through and then I received an error message. Not sure why it errored out. Could it be because I am rooted?

Rooted alone should be okay as long as you have stock recovery and have not removed apps via titanium backup. If you did any of that you will need to flash a stock 4.2.2 image to complete the update or restore from your backup.
 

S_C_B

Well-known member
Jun 22, 2010
140
3
0
Visit site
Worked for me. I had to do it twice and recheck show notifications. I'm about to install now.

Posted via Android Central App
 

quietlybrilliant

Well-known member
May 12, 2013
457
0
0
Visit site
Unfortunately since the update I am unable to update any apps. E.g.,

"Update for "Maps" could not be downloaded due to an error. (Error retrieving information from server. [RPC:S-5:AEC-0])"

Any idea how to fix this? I tried resetting all sorts of things, to no avail.
 

planoman

Well-known member
Aug 12, 2010
3,605
94
0
Visit site
Unfortunately since the update I am unable to update any apps. E.g.,

"Update for "Maps" could not be downloaded due to an error. (Error retrieving information from server. [RPC:S-5:AEC-0])"

Any idea how to fix this? I tried resetting all sorts of things, to no avail.

Remove your google account and then re enter it and restart your phone. I assume you meant you could not update from the play store? That should work.
 

TrivialTweeter

Well-known member
Nov 18, 2010
57
5
0
Visit site
Rooted alone should be okay as long as you have stock recovery and have not removed apps via titanium backup. If you did any of that you will need to flash a stock 4.2.2 image to complete the update or restore from your backup.

Thanks for the info. I haven't removed any apps with Titanium Backup and AFAIK I have the stock recovery. I did flash a custom recovery on it before, but then flashed the stock 4.2.2 image back. Maybe something is wrong with the image I flashed? Is there an "official" 4.2.2 image available anywhere?

*edit* On second thought, the "stock 4.2.2" image that I had flashed was not truly "stock". It was the only "stock" image I was able to find at the time I needed one. The image has the Browser removed(?) and was already rooted. Maybe that's the problem? I still can't find an "official stock" 4.2.2 image anywhere. Anyone know where I can find it?
 
Last edited:

planoman

Well-known member
Aug 12, 2010
3,605
94
0
Visit site
Thanks for the info. I haven't removed any apps with Titanium Backup and AFAIK I have the stock recovery. I did flash a custom recovery on it before, but then flashed the stock 4.2.2 image back. Maybe something is wrong with the image I flashed? Is there an "official" 4.2.2 image available anywhere?

*edit* On second thought, the "stock 4.2.2" image that I had flashed was not truly "stock". It was the only "stock" image I was able to find at the time I needed one. The image has the Browser removed(?) and was already rooted. Maybe that's the problem? I still can't find an "official stock" 4.2.2 image anywhere. Anyone know where I can find it?

Yes, sometimes you get errors on the update if certain files are not present. Possibly XDA has the stock 4.2.2 image.
 

Forum statistics

Threads
942,913
Messages
6,916,485
Members
3,158,736
Latest member
Dawncompton