How do I enable Ant+ on the ZU Gpe?

Standroid43

Active member
Mar 16, 2014
27
0
0
Visit site
The Xperia version of the Z Ultra lists Ant+ support as a prominent feature - not surprising, since Sony was one of the originators of Ant. So, the hardware must be here in the phone, right?

So, how do I convince KitKat to talk to the Ant+ hardware?

I installed the Ant+ Plug-ins from the Play Store as well as the Ant+ Plug-in Sampler - a demo and test app. The app reports: "Ant adapter not available..." I have a Garmin Ant+ heart rate belt, but I am not getting close to pairing the phone with the belt - I need to convince KitKat to talk to the Ant+ hardware first!

Any suggestions?

Stan

Sent from my C6806_GPe using Tapatalk
 

zedorda

Well-known member
Mar 16, 2011
2,594
179
0
Visit site
Quote pulled from link below:

ANT+ Certified models include: C6802, C6806, C6833, C6843, XL39H, SOL24, SGP412,

*Note: there is a known application compatibility issue that impacts support on Sony Xperia Z Ultra (running Android 4.2) for legacy applications that use old ANT system libraries. This situation is temporary. Efforts are underway by Sony and third party ANT Library suppliers to provide updates that ensure backward compatibility of ANT apps on Android.

THIS IS ANT - Xperia Z Ultra
 

Standroid43

Active member
Mar 16, 2014
27
0
0
Visit site
Thanks for the quick response!

That referenced 4.2. They apparently didn't get it fixed in time for 4.4. I hope it's in 4.5.

Sent from my C6806_GPe using Tapatalk