How do I fix, calendar on phone duplicating holidays?

A

AC Question

The calendar on my phone is duplicating all holidays.
My Google calendar on my laptop only shows them once.

Any advice on how to fix this?
 

srkmagnus

Retired Moderator
May 23, 2010
13,434
210
0
Visit site
re:

The calendar on my phone is duplicating all holidays.
My Google calendar on my laptop only shows them once.

Any advice on how to fix this?

Open the calendar app and open the settings. There should be am option to display calendars. Click that and check to see that there are no calendars checked that shouldn't be. I have my Gmail calendar, US Holidays and weather selected and don't have issues. Let us know if you are able to fix it.

Sent from my Nexus 5 using AC Forums mobile app
 

Andy Marshall1

New member
Jul 3, 2014
2
0
0
Visit site
re:

S Planner - Calendars - Display - I have my task, family birthdays (from Google), Holidays in US, Holidays in UK and my Google calendar checked.

The duplicates aren't because I have both US & UK Holidays as it duplicates both. For example Boxing Day is only in the UK, it shows twice, Christmas Day is in both, so shows up four times.
 

shelby456

New member
Jul 10, 2014
2
0
0
Visit site
re:

I am having the same problem. I have my phone synced with my google account and no others. I have it set to show United States Holidays. If I look at my calendar on my desk top, I don't see duplicate holidays. But when I pull up my calendar on my SGS3, some (not all) of the holidays are duplicated. For example, July 4, Labor day, and Thanksgiving are all duplicated, but Veteran's day, Christmas, and Patriot's day are not. Does anyone out there know how to fix this? Thanks
 

ChrisM1968

New member
Jul 23, 2014
1
0
0
Visit site
re:

It took a while but here is how I finally fixed this issue.

On my pc under google calendars, even though the holidays were only showing up once there, I unsubscribed to Holidays in the United States. I synched the calendar on my phone and they were all gone. I then went back on my pc and re-subscribed to Holidays in the United States, resynched on my phone (I had to go back into calendars, display, and check the box for Holidays) and they were back but only one time.
 

Don Green3

New member
Dec 2, 2014
1
0
0
Visit site
re:

I solved this by going to the stock Calendar app (not the Business Calendar app I use, which apparently is controlled by the stock Calendar app), pressing the lower left corner of my Note II to get a menu, selecting Calendars, then deleting the calendar that said "Birthdays". That got rid of the duplicates. Since birthdays already show up on my main/online Google calendar, syncing that with my Android phone brings those in to the Android calendar.

I was also having a problem with holidays showing up twice in the Android calendar, and solved that problem by deleting the Holidays Calendar in the stock app. Now I have holidays showing only once, since they are also in my main/online Google calendar.
 

pkcable

Q&A Team Leader, VR Expert
Ambassador
Jun 8, 2010
3,583
28
48
Visit site
Re:

Hello,

I went into settings, then calendar & tasks. Unchecked all the gmails except one, holidays were then single. Thanks for leading me in the right direction.

So glad this old thread is STILL able to help someone! Also Welcome to Android Central! :)

Since you went ahead and bumped the thread anyways I marked the solution as "best answer" so it real easy to find for the next person! :)