How do I share my mobile data via hotspot and NOT re-share my WiFi

  • Thread starter Android Central Question
  • Start date
A

Android Central Question

Previously, when I turned on personal hotspot, WiFi automatically turned off. Similarly, when I turned on WiFi, hotspot automatically turned off. This was fine.

After a recent update, when hotspot is on and my phone connects to WiFi, the hotspot stays on and my phone stupidly starts re-sharing my WiFi, instead of my mobile 4G/5G/LTE data!!! Why on earth would I want that???? If I wanted to use WiFi on other devices, I would connect straight to the original WiFi network, not hop the network traffic through the phone!!! I NEVER want my phone to reroute WiFi network it's connected to. I ONLY ever want to share my mobile data via hotspot. I see no options to change this back to old behaviour. How can I ensure my phone NEVER re-shares WiFi data and ONLY shares mobile data?

Somewhat related to this, every time my hotspot + WiFi are on simultaneously and I drive away from my house, thus disconnecting from WiFi, my phone pops up a question about whether I want to continue sharing data now that I've disconnected from WiFi and I have to pull over and dismiss the stupid question so I can get back to driving directions. I cannot find any options to stop this unnecessary question from popping up.

Does anyone know how I can fix above? Would even be prepared to roll back Android versions if I really required!
 

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
165,994
5,310
113
Visit site
Welcome to Android Central! Which phone? How can you tell you're actually sharing your wi-fi connection and not your mobile data connection? I agree, that's not how it's supposed to work, but I'd be curious to see where you find the information showing it's the wi-fi and not the mobile data connection that you're sharing.

Please register on this forum, which will allow you to engage in discussion more easily, as well as post images. https://forums.androidcentral.com/ask-question/409154-join-android-central-community.html
 

Mooncatt

Ambassador
Feb 23, 2011
10,839
442
83
Visit site
Welcome to Android Central! Which phone? How can you tell you're actually sharing your wi-fi connection and not your mobile data connection? I agree, that's not how it's supposed to work, but I'd be curious to see where you find the information showing it's the wi-fi and not the mobile data connection that you're sharing.

On my LG phone, the hotspot setup screen has an option to share Wi-Fi. I have no clue why you'd want to use it (maybe a makeshift network extender?), but it's there.Screenshot_20220117-123420.jpg
 

Daniel Mare

New member
Feb 9, 2022
3
0
0
Visit site
Hi thank you for your responses and sorry for my slow reply: I did not see your responses earlier, but will be sure to subscribe to see any subsequent responses.

I know it's re-sharing my wi-fi, because on my laptop connected to my phone hotspot, I Google "What is my IP address" and get an IP address from my home Internet connection, rather than one from my mobile carrier. I turn off Wi-Fi on my mobile phone and then my connected device shows the mobile carrier's IP address instead. traceroute, etc. confirms the same: definitely re-sharing my Wi-Fi connection over hotspot.

  • Phone is an Oppo A74 5G (or other Model number is CPH2197)
  • ColorOS V11.1
  • Android version 11
  • Build number CPH2197AU_11_A.12
  • Kernel version 5.4.61-qgki-g57558c0
  • Hardware version CPH2197_11

Above is my current OS version, not sure what it was prior to this upgrade that stupidly started sharing my Wi-Fi over hotspot.

The exact wording for the message I get when I drive away from my Wi-Fi network with hotspot turned on is:
"The wi-fi network has been disconnected. Continue sharing your network using mobile data?"
I then have to select "Cancel" or "Continue" - this overlays my Google Maps and I have to pull over to press Continue to see my driving directions again.

It's been months since this behavior started and I am getting more and more annoyed with it every day!

When I have Googled this, I actually found this wi-fi extender like behaviour was a very popular Android feature request : definitely not a feature I ever want!

Any advice about how to turn this off and revert old behaviour would be much appreciated!
 

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
165,994
5,310
113
Visit site
Thanks for registering and following up! That is pretty odd behavior, and may be an Oppo idiosyncrasy.

What happens if you keep mobile data on, turn off wi-fi, then turn on hotspot. Does the PC that connects to the phone's hotspot still show that it's connected to your home wi-fi, or is it connecting via your phone's mobile connection?
 

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
165,994
5,310
113
Visit site
Sounds like the simplest solution is to remember to turn off wi-fi before you turn on hotspot. Another workaround would be to use an app like MacroDroid, IFTTT, or Tasker to create a command that does both at the same time.
 

Forum statistics

Threads
945,097
Messages
6,924,182
Members
3,159,659
Latest member
sdm8700