How do I stop Android 7.0 WiFi from turning on all the time?


AC Question

I just updated my S7 Edge to Android 7.0

Now my WiFi wont stop turning on briefly every so often.
history shows that it is the gear software turning it on even though my
Gear 2classic is connected via Bluetooth.

Wifi scanning is off and location is also off.
My wifi is never used and my aim is to never use it.


Q&A Team
Aug 8, 2012

Hmmm... I'm going to take a shot at this. You have a great jumping off point referencing the Gear 2 classic. Those S2 devices have the ability to sync connect via Wi-Fi when the phone and watch are out of bluetooth range. Is it possible the settings on the gear 2 app may have gotten switched on and potentially causing this issue? Could we check just to make sure?

Samsung Gear app > Settings > Connection > is either remote connection or sync Wi-Fi profiles enabled by chance?

Visual Guide:
Last edited: