How do I stop my Contact appearing multiple times (e.g. when I search using text...)

ship69

Well-known member
Dec 23, 2013
95
1
0
Visit site
Hello

How do I stop each of my Contacts appearing multiple times when I search using text?

If I go directly Contacts ==> and then scroll up and down, each contact only appears the once.
However, as soon as I search for a name in the search bar every contact appears at least twice, sometimes three or up to SEVEN times! Nightmare. And the same problem happen whenever I look through my contacts from any other application.

I have already tried going to into Contacts ==> menu button ==> Settings ==> Contacts ==> Contacts to display ==> only the MS Exchange icon with my email address written beside it is ticked.

Fwiw, when I go to Contacts ==> (Bottom left menu button) ==> Settings ==> Contacts ==> Contacts to display
This shows a list of apps (e.g. WhatsApp, msExchange, Nine, Outlook etc) but no matter which one I select when I go back into the Contacts SEARCHING all copies of the contacts in each of the applications suddenly appear. [GRRR!]

Any help gratefully received.

J

PS
Eventually I seem to have solved this problem myself. The solution was an app.
"Simple Merger" totally failed, but so far "Duplicate Contacts" seems to have worked.
 
Last edited:

ship69

Well-known member
Dec 23, 2013
95
1
0
Visit site
Bump!

This is still an enormous problem.
I tried going Contacts ==> Settings ==> Contacts ==> Contacts to display.

But this setting only affect which contacts are displayed in the alphabetical sort list. When I search I still about 10 instances of each contact - one for each different application. NIGHTMARE!

Fwiw, I even tried the app "Simpler Merger" (which costs about £2.30)

But although it goes through them motions of merging contexts, it doesn't seem to have any affect whatsoever! [GRRR]

Any thoughts?

J