How do the inner workings of the G4 charging actually work - or do I just keep hacking?


New member
Nov 27, 2016
Visit site
In July 2016, I bought both a G4 for my wife and a G4+ for me. I bought them from Amazon because they advertised that I could use it overseas (unlocked). This turned out to be significant. Read on.

Recently my wife found the G4 was erratically charging. Fiddling with the USB in the charging port seemed to help and I got a few more charges out of it... sick patient, pain, but it was working. Finally it quit and no amount of fiddling would do anything.

  1. I plugged the G4+ into the G4's USB cable with the original fast-charge, and it worked fine charging the G4+.
  2. I plugged the G4 into the G4+'s USB cable with the original fast-charge, and it did not work trying to charge the G4.
  3. This suggests there is nothing wrong with the charger or cable, that the issue is in the G4 phone.
  4. I called Amazon (20 minutes on the phone). They said read the warranty fine print: call Motorola. Of course Motorola was closed.
  5. I called Motorola when they were open (25 minutes on the phone).
  6. By carefully explaining the trouble-shooting I already did, I avoided wasting hours with tech support that is common with overseas centers.
  7. We checked the OS because he said an earlier release could point to software. Nope, it's up to date with the charging fix.
  8. They concluded it was a defective charging port, a hardware problem that requires repair or replacement.
  9. They said I had to return the phone to them.
  10. Problem is I am overseas and the post office asks contents and then says they will not accept a device that has a battery in it.
  11. This means I have to spend $1,000 to fly to America to return the $129 phone to Motorola and then wait a week or two in America to get it back.
  12. When I came back to Amazon (15 minutes including waiting) and explained, they made a special exception and refunded the $136 on my credit card.
Nice that it was so quick, but I am still out a phone.
So I began to do some internet browsing.

I came across a strange suggestion that I should plug the phone into the charger (the phone still has 13% power and is turned off) and then press and hold the power button and the volume down button at the same time.

Miracle: the charge battery light came on. It's already up to 16%

This tends to suggest it was not a hardware defect with the charging port but something really obtuse.

So, we come to the question, and please don't answer unless you actually can enlighten.
How is it that pressing two buttons boots the battery charging cycle? What is going on?

If you don't know, but are better at sleuthing than I am, please point to somewhere else where the question has been asked and answered. I cannot find it.

Or if you have a friend with the company that actually designed and made the phone, ask them what's going on and post it as a reply. This would be very helpful for many people, so we can understand what actually is going wrong and how to fix it. As it is now, it's like the car that does not work until you kick it.

Also, if you have the same problem, and this button-pressing seems to fix it, please reply so we can build up a case for Motorola.

As a footnote, other than that the phones have been good. The G4 camera is not as good as the Nexus 5 that it replaced, but the screen is bigger and everything else seems to work OK. With the G4+ I decided not to use the fingerprint scanner, and after a few tries with the camera, went back to the Canon G9X that I carry on my belt, so except for not having the Amazon advertizing that comes with the discounted G4, I am not sure the extra money for the G4+ was worth it.


New member
Nov 30, 2016
Visit site
Hello 3727030,
I have a similar problem, but the solution that worked for you has not worked for me.
Since I bought my Moto G4 three months ago, it has seemed to charge fine and work fine in every aspect. However, one night, out of the blue, it would not charge anymore. Silly me, I let the battery get to 0%, so the phone is dead. I've tried several solutions found at online forums. When I try the solution that worked for you (press and hold power and volume down buttons at the same time while plugged in) a reboot screen appears; then I've tried to select normal start/recovery mode, but none of them do anything: the phone just goes back to being dead.
I am using the Motorola charger that came with the phone, and I have also tried to charge it with 2 other chargers that work fine for charging any other device.
I know this is not the kind of answer you were asking for, since I'm not providing an explanation or confirming the efficacy of your solution, but I post it here in the hope that you or someone else who reads this can help. If I find a solution I will post it in an edit.