HTC problem, adds "+1" voice search/commands, cannot complete call

Funkpod

Well-known member
Jul 31, 2010
469
0
0
Visit site
Whenever I hold down the search button and say "Call ____________" and it's a business that i do not have in my phone, it adds "+1" before the area code. I have a droid incredible, btw. on verizon (obviously, hehe).

i'll say "call mcdonald's" and it'll dial "+1610xxxxxxx"

However, because it adds this "+1", it cannot dial, and a verizon voice comes on and says something like,

"welcome to Verizon wireless. your call cannot be completed as dialed. please check the number and dial again. announcement 4 switch 8-4"

this is a pretty big problem, cuz i have to memorize the number and retype it and then dial it. which is like, the opposite of what i should be doing. and it's kind of hard to show off the cool Voice Search feature on your phone if you can't dial all the time...


also, htc told me that their handsets there have the problem... but it seems like my friends w/ droid X don't when speaking the same commands...

any suggestions?
 

Funkpod

Well-known member
Jul 31, 2010
469
0
0
Visit site
hey, do me a favor, when you hold down the magnifying glass, the search button, and say "Call McDonalds", what happens?

get the "+1"?
 

Funkpod

Well-known member
Jul 31, 2010
469
0
0
Visit site
Hello, I just noticed something ...

in Google Voice, my voicemail service, I notice that any number that is NOT a contact is displayed w/ a "+1" in front of it. Could this be related to Google Voice?

i don't have a Google Voice number, though.
 

Jude526

Trusted Member
Dec 13, 2010
3,936
109
0
Visit site
I am not seeing a 1 when I am dialing or a call coming in. But I did on my BB because that's how RIM wanted it
 

Funkpod

Well-known member
Jul 31, 2010
469
0
0
Visit site
The problem isn't the " 1" , it's the " +1" .verizon won't let complete a call. It's so frustrating cuz just the other day, I said " call home depot" , but it didn't work. There was " +" in front of the number. So I had to memorize the number and then manually dial it.
 

CRKhead

Well-known member
May 2, 2010
560
14
0
Visit site
The "+1" shows up in my Voice Dials, like when I tested by calling McDonalds, and the call goes through fine... A lot of my contacts now have the +1 though... It's odd...

Searching through this and other forums for "+1" isn't very helpful either... Damn forum short-speak... :)
 

Funkpod

Well-known member
Jul 31, 2010
469
0
0
Visit site
hehe, good one!

yeah, it's too tough to search, and honestly, i can't seem to find anyone else having the problem except 1 other person on a google forum... but haven't been able to connect w/ that person.

here are my questions:

1. will a factory reset help? i would HATE to do this, resetting everything up, etc. BUT, this is a pretty big feature to be missing, so I would do it if needed.
2. OR, is this a HTC problem, like, I need to talk w/ enough people who have STOCK never been rooted HTC Sense... to see if this is a Sense problem or just a ME problem.

okay...
 

Funkpod

Well-known member
Jul 31, 2010
469
0
0
Visit site
No fix yet...not that I know of, unfortunately. Same symptoms? I think it has something to do with stock sense, as rooted users don't seem to have this problem...
 

mikestorm

Well-known member
Nov 5, 2009
357
28
0
Visit site
I'm rooted with das bamf. Also I have a thunderbolt.
here are my symptoms:
google voice search adds a plus at the beginning of any number I try and call (e.g. "call Wal-mart" returns +12125551212, instead of 12125551212. triggers a verizon wireless message that says call cannot be completed as dialed.

google voice adds a plus to any number not my contacts . same verizon message when I attempt to dial right from Google voice.

since the symptoms technically span two different apps (google voice and google voice search) and two different phones that suggests it a sense issue or setting. I suspect there's a setting that doesn't overtly specify our phones are tied to the USA.

My fiance has an incredible that isn't affected. I'll compare settings on each phone and let you know.
 
Last edited:

mikestorm

Well-known member
Nov 5, 2009
357
28
0
Visit site
Made a bit of progress.

Google Voice Search on my GFs Incredible shows +1 (800)-555-1212 in the Google App, but when the number is sent to the dialer for fulfillment, the dialer shows 18005551212.

Google Voice Search on my Thunderbolt shows hows +1 (800)-555-1212 in the Google App, but when the number is sent to the dialer for fulfillment, the dialer shows +18005551212.

This suggests the issue may be how the HTC dialer app is configured. I'm going to find and reinstall the dialer apk to see if that fixes the problem.
 

Funkpod

Well-known member
Jul 31, 2010
469
0
0
Visit site
thanks for trying to diagnose the problem!

i wonder why your girlfriend's phone doesn't have this problem...

let me know what happens when you reinstall the dialer apk. would i be able to do that if not rooted?

verizon and htc's help was simply to hard reset "Use Vlingo."
i couldn't believe it!

well, i am using vlingo it's really nice, never doubted that it was nice, i just wanted to use Google's voice search app.

oh well.

let us know what happens!
 

mikestorm

Well-known member
Nov 5, 2009
357
28
0
Visit site
thanks for trying to diagnose the problem!

i wonder why your girlfriend's phone doesn't have this problem...

let me know what happens when you reinstall the dialer apk. would i be able to do that if not rooted?

verizon and htc's help was simply to hard reset "Use Vlingo."
i couldn't believe it!

well, i am using vlingo it's really nice, never doubted that it was nice, i just wanted to use Google's voice search app.

oh well.

let us know what happens!
Different ROM I would imagine. I have virtuous 3.2 installed on her phone. As for me, no dice on the phone app reinstall. Upgraded from 1.6.3 nte to 1.7 and problem persists.
 

PvilleComp

Well-known member
Jun 13, 2010
4,146
603
0
Visit site
Per the HTC Manual...

Using Assisted Dialing
Assisted Dialing allows you to easily dial international calls while roaming in another country.
Turning Assisted Dialing on
  1. Press HOME > MENU, and then tap Settings > Call > Assisted Dialing.
  2. Select the Enable Assisted Dialing check box.
  3. Under Reference Country, select the country that you want to call.
Editing a country’s international call settings
  1. Press HOME > MENU, and then tap Settings > Call > Assisted Dialing.
  2. Under Reference Country, select the country whose settings you want to edit.
  3. Press MENU and then tap Edit.
  4. Edit the Country Code, IDD Prefix (International Direct Dial), NDD Prefix (National Direct Dial), Area/City Code and National Number Length (length of phone number).
  5. Tap Save.
To reset the Reference Country to the default
  1. Press HOME > MENU, and then tap Settings > Call > Assisted Dialing.
  2. Under Reference Country, select the country whose settings you want to set to default values.
  3. Press MENU and then tap Set Default.

If you can't disable the Assisted Dialing try editing the US entry from 011 to just 1.

Hope this helps.
 

mikestorm

Well-known member
Nov 5, 2009
357
28
0
Visit site
Thanks PvilleComp, but neither disabling assisted dialing nor editing the international code from 011 to 1 helped. Still dials with plus prefix.
 

Trending Posts

Forum statistics

Threads
943,736
Messages
6,919,819
Members
3,159,196
Latest member
dgibbs83