Huawei P20 Stuck in "eRecovery" mode

limecheesecake

New member
Mar 11, 2020
1
0
0
Visit site
I put my phone on charge before I went to bed, a few hours later, not having touched my phone at all, my phone screen lights up on a screen titled "eRecovery" and a large EMUI logo, the one you usually get when updating, with the option to "download latest version and recovery" "emergency backup" "wipe data/factory reset" "reboot" and "shutdown". Having woken me up I just opted for the reboot option. I pressed the reboot button and it booted back up again on the same eRecovery screen as it was on before. As it was late I just held the off button to shut it down and would fix it in the morning. In the morning I tried the download latest version and recovery option. I selected my wifi and entered my wifi password, it went through a few stages, started updating, and when it got to 13% my phone screen went black, then rebooted back onto the eRecovery screen. I went through the process again, it got to 13%, then did the same thing. I tried to reboot it, didn't work. I tried to shut it down, didn't work. I even tried the wipe data/factory reset option as some websites online said it might help, alas it started the process and rebooted up again, back to the same screen. My phone is now stuck on this screen with nothing working, does anyone know how to fix it?
 

Trending Posts

Forum statistics

Threads
944,419
Messages
6,922,742
Members
3,159,546
Latest member
whytefrank