HUGE issues that render my Galaxy S4 a brick of crap

Mehmet Aydin

New member
Mar 30, 2014
1
0
0
Visit site
Hi,

Since the day I got my hands on my S4, not even once it worked correctly.
1)Wifi doesn't turn on, the infamous "Prevention Information" security warning comes up when you do
2) when turning on it fails to do so and starts back again, fails again ...
3) When making a call, all sound disappears completely, and this is not about the speakers
3.a) also sometimes the device freezes and the things on the screen shake and blink violently
4)When I turn it on, sound effects (like button sounds) are on for 1-2 seconds (sometimes not even that long), and when the "Prevention Information" comes up it stops
5) The USB used to connect to PC, now it doesn't. But it charges no problem, so I'm sure it's software issue
6) Sometimes it doesn't see the SIM card; a "ban" sign ( like the Ghostbusters logo, a circle with a line) replaces mobile bars

I looked everywhere on the internet, but noone has that many issues at once, and with no connection to outside world whatsoever ( no wifi no usb, maybe microSD tho) I can't do anything. I guess my OS is somehow corrupted.Suggestions?

Note: Please don't be obvious like "return it" or "do a factory wipe" etc.
 

Vsweety

Banned
Mar 24, 2014
407
0
0
Visit site
Hi,

Since the day I got my hands on my S4, not even once it worked correctly.
1)Wifi doesn't turn on, the infamous "Prevention Information" security warning comes up when you do
2) when turning on it fails to do so and starts back again, fails again ...
3) When making a call, all sound disappears completely, and this is not about the speakers
3.a) also sometimes the device freezes and the things on the screen shake and blink violently
4)When I turn it on, sound effects (like button sounds) are on for 1-2 seconds (sometimes not even that long), and when the "Prevention Information" comes up it stops
5) The USB used to connect to PC, now it doesn't. But it charges no problem, so I'm sure it's software issue
6) Sometimes it doesn't see the SIM card; a "ban" sign ( like the Ghostbusters logo, a circle with a line) replaces mobile bars

I looked everywhere on the internet, but noone has that many issues at once, and with no connection to outside world whatsoever ( no wifi no usb, maybe microSD tho) I can't do anything. I guess my OS is somehow corrupted.Suggestions?

Note: Please don't be obvious like "return it" or "do a factory wipe" etc.

At the risk of being obvious: tried power down, remove battery for 10 minutes, replace battery and power up again?
 

Trending Posts

Forum statistics

Threads
943,793
Messages
6,920,092
Members
3,159,233
Latest member
Lather7753