I have my Samsung Galaxy S4 which was 4.4.4, shouldn't it show the number change?

A

AC Question

i have samsung galaxy s4 which was 4.4.4 shouldnt it show the number change?

I hadn't updated my Samsung galaxy S4 phone in a while. and while looking at other phones on line I saw that most are running lollipop 5.0 or better. When I checked my phone in the about your device in settings, I saw its running 4.4.4 which I assumed is Kitkat. I looked and saw that an update was available but I hadn't received an notice saying there was an update available for it. After running the update, and it did say it was successful, the version number still says the same thing 4.4.4. it said all updates here loaded in successfully. My question is what version did it update too in the about your device section on the phone in settings it still says 4.4.4. is that right? Shouldn't it be changed as well? and would it be lollipop version. it didn't look like it was a very big file so it only took about 10 mins to load. Please help.
 

spagman

Well-known member
Jul 29, 2012
252
1
0
Visit site
Re: i have samsung galaxy s4 which was 4.4.4 shouldnt it show the number change?

Depending on your model S4 (i545 /I337 /L720 etc.) there might be multiple firmwares slightly upgraded with the same firmware revision.

The real way to tell would be to check "baseband" in the settings... The last 3 letters will indicate exactly which firmware is on your phone (unless you flashed a different modem).
 

Rukbat

Retired Moderator
Feb 12, 2012
44,529
27
0
Visit site
Re: i have samsung galaxy s4 which was 4.4.4 shouldnt it show the number change?

If there was an interim update to 4.4.4 before 5.0, that's the one you got. You'll have to wait 24 hours from the last update to try again (to keep people from bombarding the update servers).

It should say version 5.0 when you get Lollipop (and you might just hate the changes - I want my menu key back).
 
Aug 5, 2015
8
0
0
Visit site
Re: i have samsung galaxy s4 which was 4.4.4 shouldnt it show the number change?

try restarting the device and see if that helps :)

Posted via the Android Central App