Question I screwed up my device; TWRP is sometimes accessible

planeboy

Banned
Apr 19, 2024
18
5
3
Visit site
Well, after managing to delete the Security and PowerKeeper app, I restarted and it was taking too long to boot. It then ran out of battery and started vibrating and showing the Mi screen repeatedly.
It's now displaying driver errors on Windows like it was when it was trying to boot into TWRP. I now have ****** up my device after just deleting the Security app and running out of battery.
 
Last edited:

planeboy

Banned
Apr 19, 2024
18
5
3
Visit site
How you must be laughing. :(

Charging it for a long time and factory resetting it might fix it.
But no! It was very low on batteries when it bootlooped.
I’ll charge it for eons and see if it does anything.
I managed to brick a device by deleting one app, and it losing battery during the long bootup.
TWRP is also broken. It won’t load either. After getting root by downloading the Magisk App, it broke TWRP.
I am such a dumb*** and didn’t back anything up.
Fastboot does not do jack**** and with TWRP being broken, there is almost nothing to save my device, and guess ******* what? There is a stupid Mi account on there and it would lock the device.
 

planeboy

Banned
Apr 19, 2024
18
5
3
Visit site
Update: I am able to access TWRP sometimes, and it tries to load MIUI when I select System in the Reboot menu, but then it repeats the cycle of trying to boot, then bootloop over and over again.
I managed to access TWRP when I mash all the buttons at once and I now have a semi-functional, kind of, phone, sometimes.
It’s really strange that TWRP is sometimes accessible and from there, I could do a data wipe but I am nervous it’s gonna lock me out because of a Mi account.
What other methods can I use to reinstall the Security and PowerKeeper apps? It looks like that’s a piece of the puzzle to unbrick my device.
 

planeboy

Banned
Apr 19, 2024
18
5
3
Visit site
Installing apps in TWRP through ADB shell, or the built-in TWRP shell gives me a cannot link /libutils.so executable error that it is ARM64 (or x64) instead of 32-bit.
 
Last edited:

Trending Posts

Forum statistics

Threads
944,392
Messages
6,922,617
Members
3,159,530
Latest member
Agentofficer