I think I've bricked my phone - can you help, please?


New member
Jul 30, 2015
Visit site
Oh boy, I think I am in deep doo-doos!

The plan was to install a custom ROM on my Samsung Galaxy S4 (GT-I9505).

So, I rooted the phone and installed TWRP.
I downloaded the latest nightly ROM from CyanogenMod, as well as the Gapps and copied them to the micro-SD card
I got into TWRP Recovery and did a full backup of all data to the micro-SD card.
Having done this I thought I had done enough to protect me from catastrophe (wrong!)
Still in TWRP I did a Factory Reset/Clear Data
I did an Install of the CM 12.1 ROM
I did an install of the Gapps
All seemed fine, with no errors showing up

Then I did a reboot and this is where it all went pear-shaped!

The Setup wizard started and the first indication of a problem was numerous messages like "Unfortunately Gmail service has stopped"
This happened for all sorts of apps - Gmail, Google+, Youtube, GooglePlay, etc.
Anyway, I plugged away with Setup and it connected to wi-fi and then I got the EULA screen. When I ticked boxes and clicked "next" the screen went blank and after a few seconds it said "Unforyunately, the setup wizard has stopped"


I thought that all was not lost as I could get back into TWRP and try again or, failing that, restore the backup.
However, I cannot get into Recovery mode/TWRP - If I hold down the Vol+, Home and power buttons then I see a few lines of very small colourful text in top-left, but, when I release buttons, the phone starts up Android rather than Recovery

I have tried starting by holding Vol+ and power and the same thing happens

I have tried starting by holding Vol- and power - this comes up with a warning about using a custom OS and gives an option to cancel or continue.
If I choose continue then I set a message "Downloading.... Do not turn off target!!" and then it sits there for ages (at least an hour)

Can anyone suggest what I can do to rescue my phone?
The ideal outcome would be to be able to restore the backup I made
If this is not possible then I would like to get it back to a useable state.

Any help would be most gratefully received!

Cyngn Ray

Official Cyanogen Support
Jun 26, 2015
Visit site
Hi there, well the first thing you need to know is that you have not bricked your device. If you can boot (even with errors) your device is not bricked. What it sounds like is that you flashed a wrong gapps package for the build you are running. I personally use tkgapps found at xda when I flash. I have never had an issue with them. [GAPPS][5.1.x] Up-to-Date GOOGLE APPS (TK GA… | Android Development and Hacking | XDA Forums. You will need them to fix your issue.

So, with that being said. Take a deep breath! Being clam and clear headed is always better. Can you boot into the OS of the device, even with the errors? If so, can you skip the device setup? If so, do so. Then, enable developer options on the device and enable advanced reboot inside dev options.

Now, put the tkgapps you downloaded on your micro-sd and insert it into the device (or do it through USB and the device, whatever you are used to).

Long press the power key and select reboot, then reboot into recovery. If you can get into recovery using this method, then you are good to go. Do a CLEAN flash in recovery. Wiping for a new install. Flash the CM build then the tkgapps. Then reboot the device. Let me know how you progress.


Dec 25, 2012
Visit site
Had this problem with a S3 I use to play with. Restored to stock with odin and then used a different rom

Posted via the Android Central App

Forum statistics

Latest member