Installing Market / Play Store on Alcatel OT 979

Vanda Pachara

New member
Aug 24, 2013
Visit site
Screen Shot 2013-08-23 at 11.47.45 PM.png
Screen Shot 2013-08-23 at 11.48.27 PM.png
I am switching from iPhone to Android. I do not speak Android/PC. I speak Apple! This transition is not easy...

My new Alcatel One Touch 979 did not have Android Market / Google Play installed; however, it is a compatible phone ( Because the phone is listed as a supported device on the Google Play help page, I suspect I'm accessing an incompatible version, but I just don't know - and there are so many GP versions from which to choose. After much searching, I figured out how to get the application. I downloaded it - safely - and it was a very slow start, but now it only crashes. I tried three different platforms, each having the same outcome:

Android Market 2.3.6.apk
Google Play Store 3.5.16.apk and 3.8.16.apk

The error message reads "Sorry! The application Google Play Store (process has stopped unexpectedly. Please try again." My only option is to force close. When I log into my Google account via the laptop, I see my phone's application activity! I have a lengthy Orders list, but nothing has downloaded to the phone. To that end, when I review the "Device Manager" option in my account, nothing is listed, but when browsing the Play store and selecting applications, the compatibility indicator recognizes the phone and states whether the app is a match. How and what is happening?! The user manual for the phone is in a foreign language (Mandarin) with no English translation, so I cannot use it to troubleshoot. Here is some information about the phone:

Alcatel OT 979 Hello Kitty Made its Debut in Beijing

The micro SD is a 4GB memory and the internal memory is 126MB. I tried clearing the data and the cache. I have also tried a hard re-set, which reverts the phone back to its linguistic Beijing origins, and I needed assistance getting it to English language. If I "root" the phone, will it be revert the language? There must be a simpler way to access and use the application store on this phone...

I am out of ideas, except to wait for the iPhone 5S launch.

Thanks in advance for your suggestions :)

B. Diddy

Senior Ambassador
Mar 9, 2012
Visit site
I'm not sure if I'll be able to help you, but maybe you need to update Google Play Services. This should update automatically in the background, but maybe it isn't happening on your phone. Try installing one of the latest versions from AppBrain, since you can't access the Google Play Store: Google Play services | AppBrain Android Market

If you can't access AppBrain, you could try various sites that have the .apk installer file available for download, but I have no idea how safe these sites might be. Here's one possibility: Google Play services 3.0.25 | Sharedapk

Trending Posts

Forum statistics

Latest member