Internal Storage corruption?

Greitato

New member
Jul 31, 2018
1
0
0
Visit site
Hello. I've been having a problem for a few days now which I have tried to fix, yet was unable to, which is why i'm posting here for potential help in fixing my issue (if it even is solvable).

I run a Samsung Galaxy Note 10.1 (GTN8000) with TWRP 2.8.7.0 and CM 13 (Android 6.0) installed. Warranty already ran out about a year and a half to around two years ago, after which I rooted my device. A few days ago, I was watching a few videos on YouTube with Optimus running in the background (with Balanced Memory Settings activated). Suddenly, my tablet rebooted and was stuck on the CM boot screen for a good half hour before I decided to reboot into TWRP to just restore a backup I made a month prior. As I booted into TWRP and checked the log after starting, I saw:
"E:Mount: Unable to find partition for path '/sdcard'
E:UnMount: Unable to find partition for path '/sdcard'
E:Mount: Unable to find partition for path '/sdcard'

Updating partition details...
E:Unable to stat '/data/media'
...done
Full SELinux support is present.
E:TWFunc::Copy_Log -- Can't open destination log file: '/cache/recovery/log'
E:DataManager::Output_Version -- Unable to make /cache/recovery

MTP Enabled"
All text that is bold is red on the TWRP log.
Once I tried to restore the backup I made, I saw this:
"Restoring 3 partitions...
"Total restore size is 6575MB.
"Wiping System...
"Formatting System using make_ext4fs function.
Restoring System...
E:extractTarFork() process ended with ERROR=255"
Trying to restore the backup but now with System unchecked, the same E:extractTarFork() Error=255 happened.
Restoring Boot works fine, HOWEVER at the end, I see:
"Updating partition details...
E:Unable to stat 'data/media'
...done"

I tried repairing Data, the log says:
"Repairing Data using e2fsck....
E:/sbin/e2fsck -fp /dev/block/mmcblk0p12 process ended with ERROR=4
E:Unable to repair '/data'
E:Error repairing file system
"
When i try to outright delete Data, it says:
"Wiping data without wiping /data/media...
Done.
Updating partition details....
E:Unable to stat '/data/media'"
Trying to wipe the Internal Storage results into this:
"Wiping internal storage -- /data/media....
E:Error opening dir: '/data/media'
Updating partition details....
E:Unable to stat '/data/media'
....done"
^ this leads me to believe that my internal storage is somehow corrupted

I have also tried to reflash TWRP and my device's original firmware using Odin, however this didn't work either, resulting in "Complete(write) operation failed".

Thanks in advance for any help.
 

Forum statistics

Threads
941,655
Messages
6,910,002
Members
3,158,017
Latest member
pkd