Internal storage disappear and comes back than again disappears.

BLACKminded

Member
Jun 18, 2024
17
4
3
Visit site
Whenever I open gallery, the media shows up for 10 to 15 seconds and than disappears. After 10 to 15 seconds, it comes back to disappear again.

Using file manager results in message showing internal storage not available after I spend 15 seconds exploring files.
Every app that uses media like mx player, gallery, file managers, video Player, image viewer, downloader etc closes abruptly after few seconds of Start of any operation (reading, playing, downloading) or doesn't show anything at all.

Browsing apps like Instagram, telegram, YouTube, TikTok run fine for extended period of time but whenever they perform write operations like download etc, they get closed too or say storage not found or insufficient storage. Whatsapp will work fine until I download some media. It sometimes downloads it but mostly says storage not found or turn off USB storage or something like mount storage etc.
Infinix note 10 pro.
Non root
 

BLACKminded

Member
Jun 18, 2024
17
4
3
Visit site
Welcome to Android Central! Are you using an SD card?
I don't have an SD card in my phone. Never had I put an SD card in my phone. The problem is with internal storage.

Edit: or maybe with the system apps or packages responsible for reading and writing of data or the packages that terminate a thread by giving them a timeout etc.
I actually don't know what I typed now. I'm very new to the finding solutions on forums type of thing. Hope you understand what I'm trying to say.
 
Last edited:

BLACKminded

Member
Jun 18, 2024
17
4
3
Visit site
Never tried (don't have an SD card in phone) it but developer options does have an option, "force allow apps on external".
Also, previously I could access the android/data directory after allowing a third party file explorer to use that folder and modify it as I wanted. But when this problem started, 3 days ago, I could not access it, neither could I "allow" third party explorer to access it.
So today using adb, I installed "com.google.android.providers.media.module" and "com.android.providers.media" for user 0 because I thought that there might be a problem with them and I could read the android/data directory but can't modify it (delete the packages of apps I uninstalled suspecting that they are the culprits while they were installed a long time ago and were probably not the culprits).
 

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
166,108
5,498
113
Visit site
It sounds like something might have gone bad with the phone's internal storage ROM, then. I assume the phone is no longer under warranty?

On the off chance this is due to something you installed, see if the problems persist in Safe Mode: https://www.hardreset.info/devices/infinix/infinix-note-10-pro-nfc/safe-mode/. You won't be able to use 3rd party apps in Safe Mode, but you can test preinstalled apps to see if the behavior persists.
 

BLACKminded

Member
Jun 18, 2024
17
4
3
Visit site
It sounds like something might have gone bad with the phone's internal storage ROM, then. I assume the phone is no longer under warranty?

On the off chance this is due to something you installed, see if the problems persist in Safe Mode: https://www.hardreset.info/devices/infinix/infinix-note-10-pro-nfc/safe-mode/. You won't be able to use 3rd party apps in Safe Mode, but you can test preinstalled apps to see if the behavior persists.
Thanks
But my note 10 pro is not NFC supported (it came like this in my country I think) and there is nothing like safe mode.
Warranty expired in 2022
I'll check a local repair shop to see if the problem is with hardware or software and whether it's fixable or not.
Your response is much appreciated.
 

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
166,108
5,498
113
Visit site
The steps for Safe Mode should be the same across all variants of that phone. You're saying you can't get Safe Mode to come up with those steps?
 

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
166,108
5,498
113
Visit site
Ok, try the method here instead -- it's for the Note 30, but the XOS version looks more like yours.

 

BLACKminded

Member
Jun 18, 2024
17
4
3
Visit site
On my brother's phone (Infinix hot 30 play), I was able to turn it on, in first try. But on my phone, I tried this 11 times but was unable to turn it on.
Also;
Code:
adb shell sm list-volumes all
#Results in;
emulated;999 unmountable null
private mounted null
emulated;0 mounted null

But on the other 2 phones that I tried this command didn't show emulated;999.
Any info? What's this, how to turn it off, should I turn it off?
Mostly any command that has to do something with emulated 999 will result in permission denied.
 

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
166,108
5,498
113
Visit site
The forum software can sometimes automatically flag certain posts as suspected spam, depending on certain keywords or links. For example, one of the common keywords is "dating", which can often be used in a way that isn't suspicious, but the software will still flag it. Sometimes you just have to keep editing the post until it's accepted.

I know that some manufacturers (typically Chinese) don't allow for Safe Mode for some inexplicable reason -- but the fact that it works on your brother's Infinix phone makes this unlikely.

I'm afraid I don't know about the ADB stuff, sorry. I'm still suspecting a glitch or fault in the memory chips, so I don't think there's much you can do, since the warranty has expired.:(
 

BLACKminded

Member
Jun 18, 2024
17
4
3
Visit site
The forum software can sometimes automatically flag certain posts as suspected spam, depending on certain keywords or links. For example, one of the common keywords is "dating", which can often be used in a way that isn't suspicious, but the software will still flag it. Sometimes you just have to keep editing the post until it's accepted.

I know that some manufacturers (typically Chinese) don't allow for Safe Mode for some inexplicable reason -- but the fact that it works on your brother's Infinix phone makes this unlikely.

I'm afraid I don't know about the ADB stuff, sorry. I'm still suspecting a glitch or fault in the memory chips, so I don't think there's much you can do, since the warranty has expired.:(
Than I think it's time to reset and see. I messed up pretty bad.
Thank you very much for your time. (⁠•⁠‿⁠•⁠)
 
  • Like
Reactions: B. Diddy