Is Anyone Experiencing This?

GeneralTula

Well-known member
Dec 30, 2010
99
6
0
Visit site
I just moved to back to South Florida and while driving around today my phone has not had Data 95% of the time. I called T-Mobile and they said they aren't having any Data problems so I'm wondering of maybe its an issue connecting to the Google Servers or if I should go to Best Buy and have then troubleshoot the phone. I never realised how much with the Nexus S relies on data connections. I can't even use voice to text today.

I have pulled the battery and reset the phone multiple times.

Any I to would be much appreciated.
 

font1975

Well-known member
Dec 15, 2010
353
28
0
Visit site
Seems odd. I'm guessing signal strength is OK? Just for kicks, look under Settings/Wireless & Networks/Mobile Networks and make sure "Enable Data" is checked. And that "Roaming" and "Use only 2G" is unchecked.

After that, not sure. I would definitely go to Best Buy and try your SIM in another phone to rule out a phone issue.

You might call TMobile again and have them verify your data plan for your Smartphone is OK. When I first got the Nexus and the new TMobile account, my data wasn't working. When I called to ask why, the rep said there was an option missing on my account. It wasn't the dataplan itself, just something about enabling it for smartphones or some such thing. They added it and everything worked. Wish I thought to ask them what that option was called. I didn't change the billing or anything.
 

Smokexz

Well-known member
Aug 30, 2010
851
34
0
Visit site
Use 2g only enabled edge, he is getting no data at all... I live in South West Florida and I have data almost everywhere, especially in Miami( ESPECIALLY IN MIAMI :)). Try asking a Best Buy for their demo unit to put your similar card in or something.

Sent from my Nexus S
 

Trending Posts

Forum statistics

Threads
942,862
Messages
6,916,308
Members
3,158,703
Latest member
jraven