Is it possible to recover my apps? Lost ext3 on SD card


New member
Feb 13, 2011
Visit site
Lost my apps on SD card. Started with the SD card coming unmounted randomly, known issue with EVO I guess. Followed the recommendation of reformatting the SD by plugging it into a Windows PC and doing a FAT32 format. I backed up everything I could "see" from SD to C: drive, I could only see FAT32 partition, I think. I am running a custom ROM with APPS2SD feature and Clockworkmod recovery. I'm very new to Linix and Android but, it looks like there is a Linix Ext3 partition that is made by APPS2SD on the SD card and that is where all my apps where, including android Market app. So, upon copying all the folders back to the re-formatted SD I had no apps and no android Market to able to re-download all my apps. I guess Market is like a licensed deal that you can't just get a .apk of and reload it. I do HAVE a current recovery backup that was on the FAT32 directory of the SD card but it appears the the Ext3 partition is not in that recovery file. I tried booting into recovery with Clockworkmod and reformatting the SD again, I tried a "Restore ext3.img" but Clockworkmod comes back with 'sd-ext.img not found" so I am guessing that the Linix Ext3 partition backup was stored IN the Ext3 partition of the SD(?) and the system and data stuff is stored in the FAT32 recovery file. Brilliant idea (not)! I tried a re-flash of the ROM, flashes OK but no apps. Anyway, the SD is properly partitioned now, the FAT32 stuff is back on, I don't know how to look in to the Ext3 partition but, I know there is one program there cause I installed a file explorer by downloading and executing an .apk and there was an option to install it to SD. Going to factory reset and starting over again is not an option. Any ideas please?

Trending Posts

Forum statistics

Latest member