Is there a way for me to delve deeper into the Bluetooth stack properties?

French

Well-known member
Oct 30, 2009
914
27
0
Visit site
Is there a way to delve deeper into the bluetooth stack so I can identify what versions of hfp and opp I have?

I'm being told I have to have 1.5 and 1.1 respectively for my car stereo to be compatible with the Fascinate (running EB01). I don't have a clue how to even check this.
 

gunnermike53

Well-known member
Dec 1, 2010
3,194
652
0
Visit site
Is there a way to delve deeper into the bluetooth stack so I can identify what versions of hfp and opp I have?

I'm being told I have to have 1.5 and 1.1 respectively for my car stereo to be compatible with the Fascinate (running EB01). I don't have a clue how to even check this.

let me poke arround. i do know it supports A2DP and rA2DP.
 

French

Well-known member
Oct 30, 2009
914
27
0
Visit site
Thank you so much for trying. I'm very disappointed and frustrated. For every poster I've seen say their bluetooth stereo connection is working, I've seen one that says theirs is not. Not that there have been all that many of us to begin with. I think I've counted a total of 6 that have claimed a problem or non problem (so 3 on each side).
 

gunnermike53

Well-known member
Dec 1, 2010
3,194
652
0
Visit site
Thank you so much for trying. I'm very disappointed and frustrated. For every poster I've seen say their bluetooth stereo connection is working, I've seen one that says theirs is not. Not that there have been all that many of us to begin with. I think I've counted a total of 6 that have claimed a problem or non problem (so 3 on each side).

are you having a problem or are you looking to get a stereo?
 

French

Well-known member
Oct 30, 2009
914
27
0
Visit site
I have an actual problem. Received a JVC KW-XR810 for Christmas and only just got it installed February 10th...which was the same day I also updated my OS on the Fascinate. So I don't even know for a fact it ever worked properly.

I've tried connecting 2 other Android phones to it...one Eclair and one Froyo (epic and droid x respectfully) and they were able to make calls without getting the connection dumped. BUT...sometimes I'm able to make 2 or 3 calls with no issues...rarely. Most of the time the first call dumps the bluetooth connection upon hanging up. But the stereo and phone both show the connection being in place. I have to power down stereo and turn bluetooth off and on on the phone to get them to properly reconnect.

What kind of trouble could I run into if I flash the DL30 modem? Or the DI09 modem?
 

gunnermike53

Well-known member
Dec 1, 2010
3,194
652
0
Visit site
I have an actual problem. Received a JVC KW-XR810 for Christmas and only just got it installed February 10th...which was the same day I also updated my OS on the Fascinate. So I don't even know for a fact it ever worked properly.

I've tried connecting 2 other Android phones to it...one Eclair and one Froyo (epic and droid x respectfully) and they were able to make calls without getting the connection dumped. BUT...sometimes I'm able to make 2 or 3 calls with no issues...rarely. Most of the time the first call dumps the bluetooth connection upon hanging up. But the stereo and phone both show the connection being in place. I have to power down stereo and turn bluetooth off and on on the phone to get them to properly reconnect.

What kind of trouble could I run into if I flash the DL30 modem? Or the DI09 modem?

to answer your first post, we have Bluetooth 3.0. thats what you need to look for in compatibility.

if you flash another modem it wont do any good. the modem is cell only. the phone has a set of drivers for bluetooth. what rom are you running now?

i have a sony car stereo and the bluetooth works fine for it. i would have returned the phone day 1 if it didnt. the car dock audio not working is annoying, the bluetooth is a must.

if a device is 3.0 compatible then it should work. have you tried flashing a DL09 or DI01 stock rom?
 

French

Well-known member
Oct 30, 2009
914
27
0
Visit site
I thought Bluetooth was always backwards compatible...that 3.0 (phone) would always be able to connect to a 2.0 device?

I haven't tried going all the way back to DL09 or DI01 and seeing what happens. I've spent SO much time loading ROMs trying to find the answer that I'm ROMd out. At this point it sounds like it might the only way to further trouble shoot it.

I've tried using EB01 stock (including bloat) and a voodoo....and non voodoo. I'm on Adrynalene's now...2.4 I believe.

To attempt to further explain the issue...I can be streaming content (Slacker, mp3s, podcasts), then get a call, hang up call and the content tries to start again but then stops and then I get the "force close" vibrations with no force close message, and both the phone and stereo think they are still connected when they are not.

I can also not be streaming content (just listening to the stereo)...and take or make a call, and upon disconnecting the call the stereo resumes playing audio but my phone still ends up with the force close vibration sequence with no force close message.
 

gunnermike53

Well-known member
Dec 1, 2010
3,194
652
0
Visit site
I thought Bluetooth was always backwards compatible...that 3.0 (phone) would always be able to connect to a 2.0 device?

I haven't tried going all the way back to DL09 or DI01 and seeing what happens. I've spent SO much time loading ROMs trying to find the answer that I'm ROMd out. At this point it sounds like it might the only way to further trouble shoot it.

I've tried using EB01 stock (including bloat) and a voodoo....and non voodoo. I'm on Adrynalene's now...2.4 I believe.

To attempt to further explain the issue...I can be streaming content (Slacker, mp3s, podcasts), then get a call, hang up call and the content tries to start again but then stops and then I get the "force close" vibrations with no force close message, and both the phone and stereo think they are still connected when they are not.

I can also not be streaming content (just listening to the stereo)...and take or make a call, and upon disconnecting the call the stereo resumes playing audio but my phone still ends up with the force close vibration sequence with no force close message.

sounds like a software issue. start at di01 stock unrooted. move along the line back to eb01.

and yes bt is backwards compatible.
 

French

Well-known member
Oct 30, 2009
914
27
0
Visit site
Sigh...not the solution i was hoping for but I've tried everything...and I do mean everything else.

Gosh...could it be an actual program on the phone? That would be nearly impossible to figure out...I've got tons.

So not a good idea to go to DI01 straight to EB01? The first time I loaded EB01 I did DI01, then DL09, then EB01. Well, actually...the FIRST time I went from DL09 to DL30. And I had some major issues (force close) and then I went back to DI01, DL09 and then EB01.

And then had issues with the bluetooth stuff so went back to DI01, then to EB01.

I think I'm to the point I can almost do this stuff in my sleep now.