Issues creating Adaptive SD both with adb and with RE on S7 herolte

Xain_it

New member
Jul 11, 2018
1
0
0
Visit site
Hello everyone,

I am desperately trying to get my SD card on my S7 (SM-G930F , herolte) to work as an adaptable storage. At first, I installed LignageOS and rooted through Magisk, because why not. But I found the ROM too unstable, and the infamous camera issue was a deal-breaker for me as I really need my mobile for my research (which is why I'm trying to use adaptable storage, my internal storage is full and the mobile lagging).

So I reverted to the stock ROM, and - why not - I treated myself to the most recent firmware update, with Oreo (8.0), still rooted with Magisk.

I then tried to format my SD card through adb, as shown here, running these lines in the terminal with the USB-debugging mode activated:

Grillotalpa:~ xain$ adb shell
herolte:/ $ sm set-force-adoptable true
herolte:/ $ sm list-disks
disk:179,0
herolte:/ $ sm partition disk:179,0 private
herolte:/ $ sm set-force-adoptable false
herolte:/ $ exit
Grillotalpa:~ xain$


... to no avail. The SD stays untouched.

I then tried to format it through Root Essential, but RE requires me to flash the ASP plugin. I followed their instructions, and the phone reboots in recovery mode. But once in TWRP, no rest for the wicked:

uc


uc


I already tried to wipe everything out, format /data with another filesystem and then re-format in ext4 - that solves the "invalid argument" issue in a rather brutal way (at the cost of all my data and settings), but still doesn't allow me to flash ASP (as "Root Essentials is not installed").

Any possible way out or workaround ?
 

Rukbat

Retired Moderator
Feb 12, 2012
44,529
28
0
Visit site
32GB of storage (and whatever that gives you for userdata) isn't enough for your apps? Everything else can be stored on, or moved to, an SD card (or cards), giving you a minimum of 512GB of data storage. If you really need more space for apps, the S9 comes in a 256GB internal storage version.
 

Forum statistics

Threads
945,124
Messages
6,924,290
Members
3,159,672
Latest member
teneika lee