Issues with Google Maps anyone?

htc evo 4g

Well-known member
Jan 11, 2011
330
5
0
Visit site
Is anyone experiencing any issues with google maps ie; not completely loading up, slow load up, crashing, freezing, taking a long long time to load up with their 4GLTE? Ive updated to the latest version, rebooted, everything i could think of yet still same issue.

Running on 3g and wifi... yet same issues.

anyone else having this problem?
 

k000

Well-known member
May 12, 2012
197
4
0
Visit site
Is anyone experiencing any issues with google maps ie; not completely loading up, slow load up, crashing, freezing, taking a long long time to load up with their 4GLTE? Ive updated to the latest version, rebooted, everything i could think of yet still same issue.

anyone else having this problem?

They definitely laod up very slow, but i thought that was because of Sprint's sucky 3G..
 

Shardak

Member
May 24, 2012
13
0
0
Visit site
Its working fine for me so far. Went on a trip this weekend and used Google Maps/Navigation alot. I had none of the issues you are having.
 

htc evo 4g

Well-known member
Jan 11, 2011
330
5
0
Visit site
For example one of the problems is pictured below and it just stays like that.

Sent from my EVO LTE using Android Central Forums
 

jnl813

Well-known member
Jun 21, 2010
769
21
0
Visit site
I am definitely having problems with mine, when I search for local restaurants it gives me the whole united states ... And sometimes it's super slow to load so I'm sure there's going to be an update for it .
 

cloak.n.dagger

Well-known member
Jun 24, 2010
1,056
89
0
Visit site
For those of you having loading issues, do you have all of your location services and GPS enabled? Check in Settings>Location and make sure everything is checked.
 

cloak.n.dagger

Well-known member
Jun 24, 2010
1,056
89
0
Visit site
Hmmm, that's all I could think of. I've seen GM take a long time to load when I was having issues getting GPS to lock (on another phone). This would be a deal breaker for me as I use GM and GN all the time! However, since this seems to be an issue for only some people and not all people, I would start with the SW. Not sure if it's an option to uninstall GM or not, if you can try to uninstall and reinstall. If you can't uninstall, go to the app manager and force stop it. Clear out cache and relaunch it. If you problem persists, as a last ditch effort, I do a full data wipe on the phone and start it over from gound zero. I had a very bad GM experience on my OG EVO and a full data wipe fixed the issue. If that doesn't work, then I'd start the process for getting the phone replaced. :'(
 

Jackson Galaxy

Well-known member
Jun 28, 2011
261
35
0
Visit site
I had to use it over the weekend. The GPS locked on instatnly and I was able to drive around, search for nearby restaurants and call them at teh same time. No issues to report here.
 

cloak.n.dagger

Well-known member
Jun 24, 2010
1,056
89
0
Visit site
It might be worth a try to turn off all the GPS setting, reboot the phone, then turn all the setting back on again. Sometimes things just get stuck and you have to mess around a bit to get them to unstick! I'd try everything I could think of before doing a factory reset though.
 

Mercury81

Well-known member
Jan 26, 2012
1,138
82
0
Visit site
Everyone has issues with Google maps just check forums for proof. Like mentioned above turn off phone after use and you should be good to go.

sent from my Evo4LTE
 

Mercury81

Well-known member
Jan 26, 2012
1,138
82
0
Visit site
I wouldn't say everyone, as it seems to be working perfectly for me (and a few others that have chimed in here as well).

I just know from experience the last three phones we're always having issues with Google maps and if I turned phone of and then back on after use everything was fine. Therefore many people have had Google maps causing issues over the years. I apologize for saying everyone and those individuals who have not experienced this malfunction , please forgive me for my misinformed remark...:confused::D

sent from my Evo4LTE
 

castingon

Well-known member
Nov 2, 2010
52
5
0
Visit site
The search wasn't working right for me. It wasn't giving me anything local either. But I could get directions to a library in Colorado.
 

htc evo 4g

Well-known member
Jan 11, 2011
330
5
0
Visit site
For some reason after i let my phone charged up in the charger and i unplugged it after it was full, i tried GM out of curiosity and for some reason it works flawlessly! NO errors whatsoever. I havent moved it anywhere within the past hour and half so the signal had always been the same. I did send another feedback report to GM though...maybe they fixed it or something. :/ hopefully itll stay like this...

UPDATE:

damit damit damit. now its having the same problem again. :/
 
Last edited:

Antebios

New member
Jun 9, 2011
3
0
0
Visit site
I have also had Google Map problems since day 1 of my new EVO LTE phone. It seems like it's having a problem in certain map areas. Some areas I can zoom in fine, and some areas it doesn't download any detailed map images and then it eventually crashes. I tried GM on my old original EVO and GM is crashing also. A post I made on XDA (Does Google Map work? - xda-developers), someone said they tried it on their phone for my location and it was also crashing. So... me thinks it's a GM issue and not related to specifically the phone nor GPS, nor data connectivity.

But, I don't care what the problem is. I paid $200 for a new phone and I want everything to work. Who do I complain to? Sprint or Google?
 

Trending Posts

Forum statistics

Threads
944,504
Messages
6,923,085
Members
3,159,588
Latest member
Felichino