Lag & Battery Drain

randun

Well-known member
Jan 3, 2011
406
0
0
Visit site
I'm experiencing rather severe lag & battery drain. At first, I attributed it to switching back & forth from Wi-Fi to Mobile due to a new router. I've eliminated that as a source. Ideas?

Sent from my SAMSUNG-SGH-I337 using Tapatalk
 

Rukbat

Retired Moderator
Feb 12, 2012
44,529
27
0
Visit site
See what apps are running (SystemPanelLite). Something may be running in the background slowing the phone and eating battery.

Also check the mobile signal (battery stats, tap the graph to get to the second page). If it's not green all the way, a very weak signal can eat battery and may slow the phone.
 

randun

Well-known member
Jan 3, 2011
406
0
0
Visit site
Yup, I've got way too many apps running in the background. Also the mobile signal bar is olive, not green.

Sent from my SAMSUNG-SGH-I337 using Tapatalk
 

Lisa Call

New member
Sep 30, 2013
1
0
0
Visit site
It's Lollipop. Ever since I upgraded to Lollipop my phone drains to 50% using WiFi within less than 2 hours of internet browsing. I've done every suggestion including factory reset but still fast battery drain. I'm going to spend about $8 on a new factory battery on Amazon and see if it makes a difference. I would prefer not to get a new phone yet although I love that S6 Edge look!
 

randun

Well-known member
Jan 3, 2011
406
0
0
Visit site
It's Lollipop. Ever since I upgraded to Lollipop my phone drains to 50% using WiFi within less than 2 hours of internet browsing. I've done every suggestion including factory reset but still fast battery drain. I'm going to spend about $8 on a new factory battery on Amazon and see if it makes a difference. I would prefer not to get a new phone yet although I love that S6 Edge look!
I never updated to Lollipop. Still on KK 4.4.4.

Sent from my SAMSUNG-SGH-I337 using Tapatalk
 

Trending Posts

Forum statistics

Threads
943,727
Messages
6,919,784
Members
3,159,189
Latest member
Milaco