Location issues after update

rphx2

Member
Aug 20, 2010
5
0
0
Visit site
I just updated to gb & ever since the stock weather widget is showing my location in Chicago & I am in PA, it also adjusts the time to Chicago. My husband's Motorola Droid is also doing the same thing. I have searched for solutions & tried everything I could find including a factory reset with no luck. The only way I can keep the time correct is to turn off Google location services & then I get no weather.
Anyone have any ideas how to fix this?
 

spatrick

New member
Sep 7, 2011
2
0
0
Visit site
I had the same issue here in upstate NY a couple of weeks ago. I went to the verizon store and they said it had somthing to do with the last google maps update. I don't know if that was true but it did seem to go away after uninstalling the update. On another note this all happened around here the same week verizon was turning on the 4G in our area.
 

Darkblue31

Well-known member
Jun 3, 2010
124
44
0
Visit site
I had that same issue when I was on stock fro yo. It only happened in some parts on long island. I called Verizon and they kicked me over to HTC. The problem in my opinion is on the Verizon end. If you open maps does it place you in another area way off and then later takes a while to reset to the real spot?
 

PvilleComp

Well-known member
Jun 13, 2010
4,146
603
0
Visit site
If it's happening on both your DInc and your Husbands Moto Droid then it's not a software issue - it's likely a tower issue since the location and time come from the towers. Might be worth a call to VZW Tech support to tell them.

Also try clearing cache out for your any location apps like weather, maps, etc.
 

rphx2

Member
Aug 20, 2010
5
0
0
Visit site
Spent an hour on the phone with Verizon tech support, & then conferenced in HTC support. But they got it fixed, HTC said it is a known issue. They had me open maps & let it locate me, & then back out, which fixed the problem. I have already had to do this once or twice since I got off the phone with them to keep it in the correct location.

My husband's phone was corrected by rebooting our wireless extender.

Thanks for all the suggestions!