Missing Photos From The Gallery

jepoiski04

Member
Sep 7, 2010
7
0
0
Visit site
Hi Guys... would like to know if anyone else has ever experienced where a good number of pictures that you have stored in your Nexus S get mysteriously wiped off? I was transferring a few icons and wallpapers from my laptop and I was shocked to find out after I disconnected the phone from the PC that a majority of my wallpapers/camera pictures have gone MIA.... i am on 2.3.3

Thanks guys!:'(
 

onthecouchagain

Well-known member
Aug 12, 2010
967
17
0
Visit site
Hi Guys... would like to know if anyone else has ever experienced where a good number of pictures that you have stored in your Nexus S get mysteriously wiped off? I was transferring a few icons and wallpapers from my laptop and I was shocked to find out after I disconnected the phone from the PC that a majority of my wallpapers/camera pictures have gone MIA.... i am on 2.3.3

Thanks guys!:'(

Star the report about this issue here: Issue 13419 - android - New pictures disappear in Gallery - Project Hosting on Google Code

Hopefully a fix will come one day. In the mean time, QuickPic is a free and great alternative.
 

Jalarm

Well-known member
Aug 6, 2010
786
35
0
Visit site
I have found a reboot works very well for the disappearing pictures, but has anyone noticed the gallery is kinda slow on the Nexus S.
 

gimme#AC

Member
Aug 29, 2010
14
1
0
Visit site
Hi Guys... would like to know if anyone else has ever experienced where a good number of pictures that you have stored in your Nexus S get mysteriously wiped off? I was transferring a few icons and wallpapers from my laptop and I was shocked to find out after I disconnected the phone from the PC that a majority of my wallpapers/camera pictures have gone MIA.... i am on 2.3.3

Thanks guys!:'(
I always see this on my Nexus One whenever I re-mount the SD card after transferring files from a computer. Even if there aren't any new images for Gallery to process, it still takes awhile before Android's MediaScannerService can get everything back up to normal magic. I use a SanDisk16GB Class 2 microSDHC... dunno if this would be less of an issue were I to use a higher class card, or one with smaller storage. Most of the space on mine is taken up by MP3 files.

I've gotten impatient numerous times & tried messing with Gallery in various ways, all to no avail. But, in doing so I have found that preventing the phone's screen from sleeping (while having Gallery open) during this type of refresh CAN cause photos to permanently disappear from the external storage.
I don't know if this same bug can occur on other devices besides the Nexus One.


My suggestion? Wait a while after re-mounting your Nexus S' wonderful <16GB of expanded internal storage before trying to play around with the Gallery application.
Maybe you can preoccupy yourself in the interim by starring the bug report linked by onthecouchagain. Good luck!
 
Last edited:

jepoiski04

Member
Sep 7, 2010
7
0
0
Visit site
its kinda frustrating really. well this never happened to me on my nexus one (which the wifey has now completely fallen in love with) so it's a real bugger.
 

somerussianguy

Well-known member
Feb 4, 2011
87
20
0
Visit site
The Gallery on the Nexus S has had a lot of bugs in general - wrong images loading, taking forever to load, not loading photos at all...(I personally had to deal with all 3) Did you try to use another pictures app? I use QuickPic, much more reliable than the stock Gallery.
 

DesertSilver#AC

Well-known member
May 18, 2010
208
6
0
Visit site
Woah, woah, woah!!! My NS4G just lost about 400 pictures out of nowhere!!

When I originally saw this thread about a month ago, I thought to myself "I better find a way to backup my pics just in case this happens". Luckily, I installed Dropbox mainly to have a relatively easy way to backup a copy of my pictures off the device. I'm am so lucky I did that, or I'd be way more upset than I am right now. Syncing the pics with Dropbox is done manually so I did lose a few pics permanently, as far as I can tell, but not all 400 or so. :-[

And for those wondering, I tried rebooting the phone and even hooked the phone up to my PC and cannot see the missing pictures from the computer either. I'd say this is a serious bug.
 

Baconator

AC Adviser
Nov 21, 2010
996
122
0
Visit site
My Nexus doesn't lose the photos but it just doesn't show them to me. I installed quikpic and it works just fine.
 
Last edited:

digirati99

Member
Aug 9, 2011
11
0
0
Visit site
Hi. I am using the HTC Inspire and I have noticed that when I take a picture sometimes the pics are missing from the gallery. The pics do reappear after a while, usually after a reboot. Any suggestions?
 

Baconator

AC Adviser
Nov 21, 2010
996
122
0
Visit site
Hi. I am using the HTC Inspire and I have noticed that when I take a picture sometimes the pics are missing from the gallery. The pics do reappear after a while, usually after a reboot. Any suggestions?

Ya usually after a reboot they will appear but you can also just download quickpic which is an alternate for the Android Photo Gallery.
 

milominderbinde

Well-known member
May 25, 2010
2,163
1,179
0
Visit site
Great work everyone!

I will add this to the
---------------------------------------------------
Gallery: Nexus S owners have found relief from lost photos, wrong photos, and slow loads with the QuickPic app.
---------------------------------------------------

Looking ahead, maybe Google is focused on bringing together what has become two very different codesets and may not address many of the workarounds. Are there any other workarounds that we can document? These might help for the Prime as well.

Please PM me if there is another workaround to add or a correction needed. I can't keep up with all the threads. Thanks to Baconator for helping me find this one!
 
Last edited:

ses1191

New member
Oct 8, 2011
1
0
0
Visit site
Also experienced this on the T-Mobile G2 (Desire Z).

Found a quick solution to make the photos reappear (though it's still a mystery why this happens)



1) Menu, Settings, Storage, Unmount SD Card

2) Wait for "Unmounting..." to complete

3) Click Mount SD Card to remount it.

4) Re-open gallery app.


It'll take a few seconds to open the gallery after doing this, but all the photos re-appear.

Seems to be the "kick" that the gallery app needs to go off and take another look at what's really there...
 

dbcrum

New member
Dec 23, 2010
1
0
0
Visit site
Today I experienced the same problem. After searching and trying every option I could find nothing worked until I came across this thread. I did the SD unmount and SD Card remount and WOW, now I have ALL my pics and videos back..

Thank you ses1191 for sharing:D
 

Trending Posts

Forum statistics

Threads
942,876
Messages
6,916,358
Members
3,158,718
Latest member
Addity