MMS problems over Wi-Fi

TheMatrix31

Well-known member
Feb 13, 2011
286
6
0
Visit site
Hey guys,

For the last few months I was having trouble sending picture messages and videos over wifi. This started happening out of nowhere really, as I was able to do it for the first few months I had the One (bought it in August of 2013). It would hang and hang and hang and then finally I'd get an error message that said it couldn't/didn't send. If I turned wifi off and send the pic, it goes through fine.

Got in touch with Sprint a couple days ago and they pushed a profile update. Now it sends over wifi but it takes like 3 or 4 minutes for the little green sending icon thingy on GoSMS to fully go away to complete the send. This is happening with wifi at home and at work, which leads me to believe it's something with my phone.

Any ideas what it is? I have 4.3 on my phone (problem started happening before I upgraded to 4.3), and am not rooted.

Email support with Sprint said I should schedule a tech visit with an in-store crew but I'd rather just see what you guys have to say.

Thanks!
 

Aquila

Retired Moderator
Feb 24, 2012
15,904
0
0
Visit site
Most MMS apps default to using your mobile data if it's sent via the carrier (Spring) (as opposed via a 3rd party exchange or messaging service). If it was working before while on WiFi (my phone does this, just automatically toggles itself for that one message, etc) and suddenly stopped, then my assumption would be that something in their app or their firmware changed that allows both sets of radios to stream either simultaneously or dynamically. It's also possible something changed on GoSMS. Would it be possible to test it with the stock messaging app (from HTC) to see if it goes through smoothly on that? That'd tell us if it's an app or something on the phone (or it could be both, but if it works in one app and not another, then it's an app).
 

TheMatrix31

Well-known member
Feb 13, 2011
286
6
0
Visit site
Same major hang using the stock app. This time, it didn't even go through after a couple minutes. I opened GoSMS to look at the message I tried sending in stock and it has a yellow caution triangle on the top right. That's new.
 

ram1220

Well-known member
Oct 15, 2013
319
0
0
Visit site
Only thing I can suggest is to try Textra. I use it and don't have any problems. I know I was using Handcent on my old HTC Hero and I always had to manually log out of wifi to send an MMS. Since I've had my HTC One (October 2013) I have used Textra. No problems.
 

Trending Posts

Forum statistics

Threads
943,107
Messages
6,917,312
Members
3,158,822
Latest member
dedehammac