Moto Stylus 5G Hotspot issues


New member
Aug 15, 2022
Visit site
I have a Moto Stylus 5g (2022) & im having problems reaching the internet on a Dell laptop. Network does connect to wifi but connection says "No internet, secured" Below are the troubleshooting steps ive taken but no luck

Uninstalled/reinstalled/updated nic adapters drivers
ran netsh int ip /reset - /flushdns - /registerdns
Shortened hotspot name, tried with no hotspot pw
Changed from 5GHz to 2.4GHz
Changed Metro APN settings (mainly to use ipv4 & ipv6 (which worked for others on other forums)
Purchased a usb wifi adapter off Amazon with same results
The hotspot works on other devices & laptop connects with other hotspots. Just something between the 2 not agreeing.
Thanks for any advice here.....
Last edited:

B. Diddy

Senior Ambassador
Mar 9, 2012
Visit site
Welcome to Android Central! Just be clear -- you're saying that other devices can connect to the internet via your phone's mobile hotspot, but this laptop can't, correct?

Are there more than one device connecting at a time?