Moto X 2014 Voice To Text Not Available Via Moto Assist?

The Singularious

Active member
Sep 29, 2014
Visit site
I'm having trouble sending texts via voice command. Moto Assist seems to indicate that I can do this, as one of the suggested commands upon activation of Moto is "Send a text to ...". But when I give the command, the phone responds, "please install the app and try again".

Am I missing something. One of the main reasons I bought this phone was for voice commands other than just searching Google, which almost any late-model Android phone can do.

Educate me, peoples!

And TIA.


Dec 4, 2014
Visit site
Ok, I fixed one of my two problems. I went into apps and found my texting app (textra in my case). I then hit the clear defaults button. Then I sent a text via moto voice assist and it worked. Then I re-set textra as my default texting app and it still works.

What still doesn't work, however, is the need to unlock my device before sending a text (even though I have all three checkboxes checked for "Commands while locked". That is still annoying.

Anyway, hope this helps.