Moto X: Moto Assist not reading text messages while driving.

RM83

Active member
Aug 26, 2013
27
0
0
Visit site
I recently encountered this problem. My Moto Assist would always read my texts while I was driving. Now though it won't. Any fix for this? I went into the Moto Assist settings and the Talk to me box is checked.

Posted via Android Central App
 
Last edited by a moderator:

RM83

Active member
Aug 26, 2013
27
0
0
Visit site
Re: Moto Assist not reading text messages while driving.

Disregard this post. I fixed it. :D

Posted via Android Central App
 

Laineyc

Well-known member
Jan 10, 2012
267
3
0
Visit site
Re: Moto Assist not reading text messages while driving.

Disregard this post. I fixed it. :D

Posted via Android Central App

Yes, please. How did you fix it? I have the same issue.

Sent from my XT1060 using Xparent Pink Tapatalk 2
 

ttfn92

Well-known member
Jan 5, 2014
133
0
0
Visit site
Mine won't work thru my car's Bluetooth and it's annoying. I can talk on the phone but not hear my texts or the answer if ask it something. I have a '13 Buick Enclave. Anyone know how to fix this?

Posted via Android Central App
 

Cyder

Well-known member
Apr 19, 2010
80
1
0
Visit site
On the last update, I had to re activate the moto assist. Try checking all the options and make sure its turned on.
 

RM83

Active member
Aug 26, 2013
27
0
0
Visit site
For those of you asking how I fixed it, this right here is what I did. I went into the Moto Assist settings and manually checked the boxes and restarted my phone. It's been working well since then.

Posted via Android Central App
 

techitrucker

Well-known member
Jul 7, 2012
270
0
0
Visit site
Mine won't work thru my car's Bluetooth and it's annoying. I can talk on the phone but not hear my texts or the answer if ask it something. I have a '13 Buick Enclave. Anyone know how to fix this?

Posted via Android Central App

Go into Motto Assist then driving. Hit link you see there for Bluetooth issues. Choose alternate. Has worked on every vehicle I have that it didn't work on before.

Posted via Android Central App
 

techitrucker

Well-known member
Jul 7, 2012
270
0
0
Visit site
I don't have alternate.

Posted via Android Central App

Moto Assist... Driving... Arrow next to Talk to me... There will be a link at the bottom for Bluetooth issues. Click that. Pick bottom selection to use alternate audio channels. If it's not there you probably just need the newest update to Assist.

Posted via Android Central App
 

ttfn92

Well-known member
Jan 5, 2014
133
0
0
Visit site
Moto Assist... Driving... Arrow next to Talk to me... There will be a link at the bottom for Bluetooth issues. Click that. Pick bottom selection to use alternate audio channels. If it's not there you probably just need the newest update to Assist.

Posted via Android Central App

Thanks! I went to settings first. Didn't realize I had to hit more to bring driving up. I'll try it tomorrow.

Posted via Android Central App
 

Lisa Gatling

New member
Nov 21, 2014
1
0
0
Visit site
I have both the Droid Turbo and 2014 Moto X after last updated neither will read messages over Bluetooth in my car i preferred the way assist was set up with the alternate channel

Posted via the Android Central App
 

cz9h3d

Well-known member
Sep 16, 2010
79
0
0
Visit site
Got my wife the Moto X specifically for the in-car texting (i.e. Moto Assist Driving Mode). As a Windows phone user, I assumed the experience would be similar - the phone interrupts whatever the current audio source is, lets you know a text has been received, and asks if you want to hear it.

She has a 2014 GMC Terrain, with Intellilink (or MyLink in Chevy speak).

The issue: Sometimes the audio program will be interrupted to announce the text and ask if you want to hear it - at other times it doesn't interrupt the audio. Radio source is XM.

When playing with it yesterday, I couldn't get it to work at all unless the audio source was the phone. I turned the bluetooth setting in Moto Assist to alternate source. Still didn't work.

Then today - sometimes it worked when on XM!!!! But not every time....

Thoughts?????
 

technophile31

New member
Jun 10, 2013
2
0
0
Visit site
Sorry for replying on an old thread but I'm having similar issues as stated above.. I have a 2015 Elantra and play music through Poweramp over Bluetooth, and when I get a text in the car my moto x starts to speak but the music plays over it so I can't hear it and it can't hear me reply... And the settings in Moto have been updated so that the alternate source option is no longer there. If anyone has any advice please share,I'd be super grateful!

Posted via the Android Central App
 

Groid

Well-known member
Dec 14, 2011
148
0
0
Visit site
On my 2013 Moto X 4.4.4 the alternate audio channel does exist. Assist (2.5.4) > Driving (check Talk to me) > three vertical dot menu > Settings > Audio troubleshooting > choose Alternate audio channel. Please check your settings again.
 

Forum statistics

Threads
943,960
Messages
6,920,794
Members
3,159,328
Latest member
Moore Rebecca