• Welcome to the all-new Android Central Forums! - We're still moving some things around, so you may see a few quirks here and there, but we're working on getting things fully completed as soon as possible. For now, take a look around, and if you run into any major issues, please let us know in this thread!

My nexus 7 2012 does not start


AC Question

It runs KitKat 4.4.4. I switched it off (as it was stuck during browsing) and then it did not open again. I put the charger, I saw the battery icon, switched it on again but it did not boot or open.

I tried any combination with the keys to see the boot loader -- no result. The battery was at about 40%. It seems that there is a hard problem. It did not shut down properly...

Now putting the charger cannot see the battery icon. It is completely dead.
Any suggestion what hardware part could be dead (except the battery)?


Co-Ambassador Team Lead
Jun 10, 2014
Have you tried pressing and holding Power and Volume Up+Down for a minute or so?

Posted via the Android Central App