My Nook Color isn't able to play any video files!

wangdw611

New member
Feb 9, 2011
2
0
0
Visit site
So I bought a nook color and tried to install nookie froyo on the internal storage. That went terribly wrong so I used one of the methods on xda to return the nook to stock. I then proceeded to upgrade to 1.1 and root it but keeping the stock rom.

Now, I'm trying to watch videos on the player and it's giving me "This file cannot be played with System Player" whenever I use Astro to navigate to my SDcard and try to play it using Rockplayer Lite. The video files are in xvid .avi format. Does anyone know of any solutions to this? Help would be much appreciated!
 
Last edited:

chaloney

Well-known member
Nov 10, 2010
112
11
0
Visit site
Video files need to be mp4. I've tried h264 video with Aac audio in an mp4 package--wont work. Must be mp4 video, aac audio, saved as mp4 file type. Stock video player will only play if audio is 2-channel (stereo). I accidently ripped some DVDs without changing the audio to stereo (left it as 5.1) and stock player wouldn't play it at all--said it wasn't compatible. Rockplayer tried but sound was all messed up.
 

gpklemann

Member
Apr 19, 2010
6
0
0
Visit site
There is an easier solution to this problem. This happened to me with the full version of Rockplayer. The first time I played a divx everything worked great. Then without reason it stopped. Simply by going under menu and clearing the playback history the nook went back to playing divx's without problems in rockplayer. Hope that helps.
 

Legobricke

Well-known member
May 20, 2010
551
9
0
Visit site
The issue I had with rock player that gave me the same error was due to me selecting HARDWARE ENCODER and not SOFTWARE ENCODER.

Try switching off the HARDWARE ENCODING.

Lego
 

sid00702

New member
Feb 16, 2011
2
0
0
Visit site
Rooted Nook Color CM7 can't play youtube

Just rooted nook color with latest CM7. Can't can Youtube app to play any video. Go direct to youtube website won't play video also. Flash 10.1 works on other website. Please help.
 

Paladin

Well-known member
Apr 26, 2010
470
29
28
Visit site
I think it is just Astro, I also noticed it says from Astro with RockPlayer or anything else. Astro is not good at launching the player.

Try just opening the files from Rockplayer directly and they should work fine.

Here is where it gets weird. I just tested it for you to make sure it was working and I was getting that error.

So under settings I made sure the Hardware decoding mode was not checked. It was checked because I was playing with it before and was getting sync issues without that on. So I turned it off and the video played. I was again getting sync issues so I turned it back on and it played fine.

Somehow it needed reset somehow but for me it plays fine with the hardware decoding on.
Now it seems this is for MP4 files. Other files only run with software decoding. It is weird. :)

So play with that setting directly from Rockplayer.

Take it for what it is worth. :)
 
Last edited:

Legobricke

Well-known member
May 20, 2010
551
9
0
Visit site
I have used Rockplayer, QQ Player, and arcMedia.

Testing with a avi file I found that arcMedia so far has playedback the best. No lag and no sync issues.

Rockplayer was a very close second.... QQ player was just plain bad.. dropped frames... sync issues and serious banding.

These files were played off the sd card and not the internal....

Lego
 

TuxHacker

Member
Mar 7, 2011
8
1
0
Visit site
Just rooted nook color with latest CM7. Can't can Youtube app to play any video. Go direct to youtube website won't play video also. Flash 10.1 works on other website. Please help.

CM7 - Known issues with graphic acceleration.

I was on CM7 but watching videos a lot on NC so I went back to stock + rooted + OC. :)
 

Legobricke

Well-known member
May 20, 2010
551
9
0
Visit site
Of all four players... (RockPlayer, QQ Player, arcMedia, Vital Player) I must say that Vital gives me the best picture quaility.

This is while running .avi files.

This is what I have observed using the stock root with auto nook:

This is also using only software decoding.

Rock Player - audio in sync / video quality ok
QQ Player - audio in sync / video quality poor (also dropped frames)
arcMedia - audio in sync / video good
Vital Player - audio lags / video excellent

I am still playing with Vital to see if I can get it set so the audio doesn't lag. If I can get it working, this is by far the best player out there for avi files.

Lego