My note 4 takes more than hour to charge from 80 too 100%

Khaled Mahmoud1

Active member
Jan 31, 2016
26
0
0
Visit site
Hi everybody
I have a problem with my note 4 n910c on android 6
The device takes time more than usual to charge. I used to charge it from 0 -100 % in about 90 minutes.
But lately it takes more than 2 hours to charge. From 0 to 80% it takes about one hour and this is normal but from 80-100% it takes more than an hour. Does anyone have the same problem and how can I solve it?
I tried discharging the battery totally and charging it while device is off and the problem still exists. I tried also clearing the cache partion and nothing changed.
 

Morty2264

Ambassador
Mar 6, 2012
22,922
1,053
113
Visit site
Welcome to the forums! How long have you had your Note 4? While it is normal for older phones to encounter battery/charging hiccups, the problem you mention seems to maybe point to a battery that is closer to the end of its lifespan.

Are you using the charger/cable that came with your phone? Have you tried others to ensure that the problem indeed lies with the battery?
 

Morty2264

Ambassador
Mar 6, 2012
22,922
1,053
113
Visit site
It's only less than a year and I'm using the original charger and unfortunately I have no other fast charger to try it.

If you're using the original charger and cable that came with it, there is a chance it could be that the battery is wearing out. Bring it to your carrier's store and see if their fast chargers (I'm sure they have a couple lying around) give you a similar result when your phone is plugged in at 80%. Let us know what happens!
 

armin80

Member
Feb 17, 2014
15
0
0
Visit site
Hi everybody
I have a problem with my note 4 n910c on android 6
The device takes time more than usual to charge. I used to charge it from 0 -100 % in about 90 minutes.
But lately it takes more than 2 hours to charge. From 0 to 80% it takes about one hour and this is normal but from 80-100% it takes more than an hour. Does anyone have the same problem and how can I solve it?
I tried discharging the battery totally and charging it while device is off and the problem still exists. I tried also clearing the cache partion and nothing changed.
Just change the charger cable