Need for Speed Most Wanted not Compatible with Nexus 7 (2013)

zhingket

Well-known member
Oct 7, 2011
69
3
0
Visit site
I am trying to install the Need for Speed Most Wanted to the new Nexus 7 but I got this message, is anyone else having this incompatibility issue? But I have it on my old one.

untitled.JPG
 

Percy Young

New member
Aug 2, 2013
1
0
0
Visit site
I was having the same problem when i go to play store to down load the app does not show at all, but using a lesser power tablet it shows up in play store. I guess the app cant run under faster processor like you said i have it on the older nexus 7
 

Diknak

Well-known member
Dec 9, 2012
457
0
0
Visit site
Email the developer, but they most likely know about it. They probably don't enable it for devices that they haven't tested it on.
 

tflash

Well-known member
Sep 20, 2012
330
0
0
Visit site
Email the developer, but they most likely know about it. They probably don't enable it for devices that they haven't tested it on.

This is true for a lot of apps. The 'Smart Tools' app would only show images from the front camera. I e-mailed the developer and they hadn't event heard of a new N7. (sorry Google, I still call it e-mail and not gmail, and a tissue is not a kleenex! ;-) )
 

Sandeep Tamhankar

New member
Dec 13, 2013
1
0
0
Visit site
Yeah, I am very disappointed about this as well. However, the description (What's New) on Google Play says it works on the new Nexus 7. So maybe the problem at this point is that the developer needs to register it as "new Nexus compatible" when publishing the app.

I really can't wait for this to be resolved. I broke my old Nexus 7 a few days ago and really miss this game (as does my 8 year old son).
 

Forum statistics

Threads
945,099
Messages
6,924,164
Members
3,159,663
Latest member
reaghsj6465