Need help with my HTC Amaze Ruby Asian(unbranded)

Jamil arif

New member
Aug 10, 2013
Visit site
I bought used htc amaze a month ago with Locked bootloader with GB(probably 2.3.4) running and S-ON.It is the plain Htc Amaze, not t-mobile etc.. After few days of buying, i planned to install some custum rom in it. I took guide by googling and download "Hasoon HTC Amaze toolkit All-in-one". This worked for me and i successfully unlock the bootloader and installed TWRP recovery.I downloaded simple custom rom (Named Amaze 4g) and put zip in sd. I wiped up cache and whatever to be wiped and installed rom successfully .Then wipe dalvic cache...O.K done!!! BUT What's this? When i reboot it stucked on HTC boot logo. It is 4 days from now that this happened and i am trying day and night to turn it power on but FAIL FAIL FAIL FAIL!!!!

My HTC's current status at boot loader is

****** Security Warning*****
Feb 29 2012, 12:06L37

I had tried the following things to turn it on but every time it stucks on HTC boot logo.(AGAIN reminding you, its and asian htc amaze)

--> Tried different RUU for T-Mobile, TMOUS, Telus, Globalive.... Installed it...either they don't install at all or if install then again stuck in HTC boot logo.

--> I had downloaded various stock zip rom of ICS and JB and after renaming to, had drop inside sd card. Then locked bootloader again, but after installation, it gives the error

in hasoon toolkit = FAILED (remote: 41 model id check fail)
in cell phone = Model id incorrect!

I think this is due to that my htc is S-on.but read below i tried to s-off....

--> I tried to S-off my phone but its requirements is to must have "stock RUU" and i don't think that mine had stock RUU. OK whatever i still tried it throigh ubuntu live cd with ControlBear....this stops at the line "checking adb connection". I think because it checks if phone is powered on but my phone, at that time, is still stucked in HTC boot logo.

--> Also their is some stock roms that gaves error "Signature verification fail!!"

I am trying my best for many days to somehow boot it to homescreen. Please help Whatever rom, stock or custum or whatever
Thank You!


May 30, 2013
Visit site
From what I've read (Sorry if I get this wrong) you locked the bootloader? You need to make sure that is unlocked. And about the "checking for ADB connection" you need to go into the recovery and choose fastboot or adb sideload if you choose to use ADB. Also try wiping cache and dalvik and wiping the phone. My ADB is a little rusty so I can't give you any commands. Hope this helps


Well-known member
Dec 16, 2011
Visit site
I use CWM recovery on mine. I haven't turned S-OFF (yet), but I think you may need to return it to stock and start over. Unlock, flash recovery with CWM (or just boot to it via fastboot), do a full nandroid backup to the removable microSD card (so you then have a backup of the stock partitions that you can restore), then start the ROM flashing. It's not mandatory, but might be a good way to get to square one, CYA, then start playing.

I believe there are instructions on for returning the Amaze (T-Mobile, or international) to stock.