Need urgent help with battery/android wear

Joao Mouco

Member
Aug 4, 2015
5
0
0
Visit site
Hi guys, so i just got a moto 360 on the 31st of July and till now im disappointed with it.
The thing is after i have read may posts about the battery life the conclusion i get is that i need to give some time to the watch so the battery can "normalize"?. It´s so bad right now, if i leave the watch home without any use i get a 10% drop in about 4 hours, but as soon as i put it on my wrist i can literally see the battery drop % by %.
So should i give the watch a few more days and charges or should i be worried and return it?

Another issue i have it´s with the android wear app. I can't seem to find that gear icon to go to the definitions. I simply can´t access the definitions on the app on my phone.

11823933_936992459693561_823191870_n.jpg
PS: I've tried some steps to improve battery life but to no success. They included reseting the watch and cleaning cache etc..
 

NovaFox238

Active member
May 25, 2010
25
0
0
Visit site
Sounds like what happened to me... I tried everything possible to fix the battery... Read every forum possible and looked around for help. I ended up having to return / exchange mine 2 times before he 3rd one became the charm. First one has severe battery drain as you speak of. Second one died, and wouldn't turn on at all no matter how many hours I had it on the charger. 3rd one is running great, had it since Saturday, batter seems to be getter much better. Can do about 18 hours on one charge so far.

Exchanging it was a super hassle... But fortunately there was a Best Buy around wherever I went. I'm not saying that's you're only option, but it sounds like what happened to me as well. Although, one question. Are you running a custom rom or stock on whatever phone you're using?

Posted via the Android Central App
 

Joao Mouco

Member
Aug 4, 2015
5
0
0
Visit site
Thanks for the feedback man. I'm using a stock rom on my oneplus one. I think i've set my mind on exchanging this one. Nothing seems to timprove battery.
 

NovaFox238

Active member
May 25, 2010
25
0
0
Visit site
Thanks for the feedback man. I'm using a stock rom on my oneplus one. I think i've set my mind on exchanging this one. Nothing seems to timprove battery.

Yeah it wouldn't hurt to exchange. I loved the moto360 enough to keep giving it chances lol. Finally got the "good" one.

Posted via the Android Central App
 

Joao Mouco

Member
Aug 4, 2015
5
0
0
Visit site
Regarding the android wear problem i have can someone help me?
The process of pairing gave me problems to start with. I couldn't pair my watch to my phone trough the app and could only do it trough the normal means of pairing a device to a phone trough Bluetooth. The thing is moto connect says my watch is connected....
 

NovaFox238

Active member
May 25, 2010
25
0
0
Visit site
Regarding the android wear problem i have can someone help me?
The process of pairing gave me problems to start with. I couldn't pair my watch to my phone trough the app and could only do it trough the normal means of pairing a device to a phone trough Bluetooth. The thing is moto connect says my watch is connected....

That's odd... Because when I had the issues with my previous 2 devices, the first took about 30 seconds to connect, the 2nd device took about 2 times to try to connect, and the final "good device" I got connected nearly instantly. I really wish I could pinpoint a certain problem... Whether it's the 360 being defective or Android Wear in general... But my money would go on defective units. I had the Wear problem the first time around too. Again tho, am no expert. Just going on what has happened to me. Have you tried wiping you're phone? After backing everything up of course. It's worth a shot if you haven't already.

Posted via AC App on my Nexus 6
 

Joao Mouco

Member
Aug 4, 2015
5
0
0
Visit site
I should try that yeah. the thing is that my setup of the watch doesnt look like anything i've seen online. When i open android wear for the first time it takes me directly to the main menu thus bypassing the connection procedure of the watch. The workaround if found for this was pair my watch to my phone through my bluetooth menu as you would do with another device. Then i cn control my watch trough android wear but i dont get the setting "gear" as you would expect. I simply dont have any settings whatsoever. In a few days i will try with another phone and if i can't get the watch to work correctly i will return it to the store. Idk man im just so disappointed with my moto 360. I'm even considering buying a asus zenwatch...
 

NovaFox238

Active member
May 25, 2010
25
0
0
Visit site
I should try that yeah. the thing is that my setup of the watch doesnt look like anything i've seen online. When i open android wear for the first time it takes me directly to the main menu thus bypassing the connection procedure of the watch. The workaround if found for this was pair my watch to my phone through my bluetooth menu as you would do with another device. Then i cn control my watch trough android wear but i dont get the setting "gear" as you would expect. I simply dont have any settings whatsoever. In a few days i will try with another phone and if i can't get the watch to work correctly i will return it to the store. Idk man im just so disappointed with my moto 360. I'm even considering buying a asus zenwatch...

Yeah, I don't blame you one bit. I'm surprised how patient I was with the 360. But now that it's running smoothly, I guess I can't complain. Hopefully it all works out for you. If not, a ZenWatch is always looks like a good choice too.

Posted via AC App on my Nexus 6
 

renzi555

Member
Mar 15, 2010
20
0
0
Visit site
I've had one since launch and battery has never been a problem. HOWEVER, there is some bug or something with the most recent Android Wear companion app. It's been killing my battery in about 6-7 hours, starting this past week (I used to have 20% left at the end of the day). Several reviews on the Play Store agree with my findings. That's with ambient display off.
 

Zammo76

Well-known member
Nov 21, 2011
69
0
0
Visit site
I'd say your drain is down to the way you have the watch connected to your phone. Why don't you ring Motorola support and see if they can help you with your issue?

Also have you tried un-installing and re-installing Android Wear to see if this jolts the phone into connecting to the watch properly?
 
Last edited:

LowIQ

Well-known member
Nov 5, 2011
193
0
0
Visit site
if you downloaded or installed the 'Gmail-Wear' app to cause what you are experiencing.... I had the same thing happen with me, so I uninstalled all the wear apps to put them on one by one to test which one caused the problem?... it was only after I found the 'Gmail-Wear' app to go on the forums to find others in the same predicament....
 

Trending Posts

Forum statistics

Threads
941,387
Messages
6,908,534
Members
3,157,897
Latest member
driodPixel