Nexus 4 keeps reconnecting-disconnecting to my PC.

Waterdroid

Well-known member
Nov 6, 2013
111
0
0
Visit site
Hi all,

My N4 is acting strange when connected to my PC (Win7) via a micro-usb cable.
Whenever it is plugged in in both my USB 3.0 or 2.0 port and the micro-usb port on the N4, my N4 will keep connecting and disconnecting for as long as it's plugged in. It goes very fast, almost as if someone is repeatedly turning a flashlight on and off. My screen will keep waking up and my PC, strangely enough, does nothing since I haven't been able to find my N4 at 'My computer' for the last week (tried about everything with drivers). I've tried about 3 micro-usb cables and they all do the same.

I think either the usb flex in my N4 is damaged or something else is going on in my device, it could be water damage since I have been in a few rainy days where I'm sure my device has gotten pretty wet. Question is, what can I do to fix it? I don't know anything about 'RMA' and such, I live in the Netherlands and got my phone in Germany.

Thanks for your help guys.
 

ToastQ

New member
Feb 7, 2013
1
0
0
Visit site
I'm having the exact same problem! Although with me it was working fine until I tried installing drivers, and then it all went to hell. It's immensely frustrating though, because I really don't know what to do.
 

Waterdroid

Well-known member
Nov 6, 2013
111
0
0
Visit site
Okay, so it wasn't the hardware. It was indeed the drivers.

For some reason I fixed this, without a clue what actually did it. I installed the Google USB Driver via SDK Manager (installed with the help of this guide) and got my phone to be usable with my PC (no disconnecting and connecting anymore) and use it with no USB-debugging enabled as an MTP-device.
However, I still couldn't get my ADB working, turns out that if I enable USB-debugging, then uncheck MTP and replug my device in the usb-port, it'll get recognized as ADB device.

Sorry for the unclear explanation, it's the best I can do.
Good luck ToastQ!
 

rcav8

New member
Feb 2, 2016
2
0
0
Visit site
It is a USB Power setting
1. Go to Power Options on your computer
2. Click 'Change plan setting' on your chosen plan.
3. Click 'Change advanced power setting' on your chosen plan.
4. Expand 'USB Settings' .
5. Expand 'USB selective suspend setting' and change it to disabled.for On battery and Plugged In
 

Trending Posts

Forum statistics

Threads
945,912
Messages
6,927,650
Members
3,159,992
Latest member
shahraiz002