Nexus 7: fixed screen lag

Feb 28, 2014
6
0
0
Visit site
From Settings.. Developer.. then,
Turn Force GPU rendering off
Turn Force 4X MSAA on
Turn Disable HW overlays on
.. everything else unchecked.

No more lag and no more sticky screens.
Hope it works for you too.
It's really fast now.

Dennis
 
Last edited by a moderator:

joe_fresh

Trusted Member
Mar 13, 2013
644
0
0
Visit site
Re: fixed screen lag

You can also turn on art in the developer section as well,

Posted via Android Central App nexus 7
 
Feb 28, 2014
6
0
0
Visit site
Re: fixed screen lag

I was only trying to fix the very bad screen lag and failure to respond to screen taps.
.. that was driving me nuts.. I was about to junk it.
All fixed now.. It's great!

Not sure what "art" does?

Dennis
 

mikemike162012

Well-known member
Jul 9, 2013
137
0
0
Visit site
Re: fixed screen lag

Hmm... Interesting does this also fixed the problem where the screen missed touches when laying it flat on the table? I just wrapped my device ready to be sent in for repair. Curious!
 
Feb 28, 2014
6
0
0
Visit site
Just tried it and it seems to.
I never really used it like that.
Mine never worked even when I held it in my hand.
.. best part is the keyboard works WAY be better. I guess it was unable to figure out what was being swiped.
.. and I also changed from Davirk to Art and it does seem even more responsive.
It is really amazing.. I was going to junk it and now it is fabulous.
 
Feb 28, 2014
6
0
0
Visit site
Turning on antialiasing (MSAA) to fix touchscreen bugs makes absolutely no sense to me. Keep in mind that all these settings cause the CPU to do more work, which leads to faster battery drain.

If you want a real fix, try this one (or exchange your device):
Take that multi-touch! Fix and lock in what works for YOU regardless of updates - xda-developers

Posted via Android Central App
I just turned MSAA off and the tablet is still blazing fast so I guess you are correct.

Actually, I've now just turned off EVERYTHING in the developer section and the the speed and touch issues are still fixed.
I have only ONE check box on in developers and that is the "stay awake" button..
.. EVERYTHING else is unchecked.

I did install the new Google search launcher yesterday.. Not sure if that is having something to do with all this?
 

Relgoshan

Well-known member
May 16, 2011
1,057
8
0
Visit site
The next time I get access to an N7 2013 I should tamper with this. The only two I've seen had choppy scrolling and render lag in apps like YouTube. My Snapdragon 400 based tablet "weighed down" with TouchWiz was running rings around the N7 and I chalked it up to the slower CPU core struggling with display scaling.
 

NoraMelua

Well-known member
Mar 6, 2013
127
0
0
Visit site
The next time I get access to an N7 2013 I should tamper with this. The only two I've seen had choppy scrolling and render lag in apps like YouTube. My Snapdragon 400 based tablet "weighed down" with TouchWiz was running rings around the N7 and I chalked it up to the slower CPU core struggling with display scaling.
That's certainly not the usual behavior of a N7 2013. It's still one of the fastest tablets around.
 

Forum statistics

Threads
943,752
Messages
6,919,919
Members
3,159,214
Latest member
fishbillaros